---
id: CVE-2011-4899
title: >-
  wp-admin/setup-config.php in the installation component in WordPress 3.3.1 and
  earlier does not ensure that the specified MySQL database service is
  appropriate, which allows remote attackers to configure an arbitrary database
  via the dbh…
summary: >-
  wp-admin/setup-config.php in the installation component in WordPress 3.3.1 and
  earlier does not ensure that the specified MySQL database service is
  appropriate, which allows remote attackers to configure an arbitrary database
  via the dbh…
severity: high
cvss: 7.5
cvssVector: 'AV:N/AC:L/Au:N/C:P/I:P/A:P'
vendor: wordpress
product: wordpress
affected:
  - wordpress <= 3.3.1
  - wordpress = 0.7
  - wordpress = 0.71
  - wordpress = 0.72
  - wordpress = 0.711
  - wordpress = 1.0
  - wordpress = 1.0.1
  - wordpress = 1.0.2
  - wordpress = 1.2
  - wordpress = 1.2.1
  - wordpress = 1.2.2
  - wordpress = 1.5
  - wordpress = 1.5.1
  - wordpress = 1.5.1.2
  - wordpress = 1.5.1.3
  - wordpress = 1.5.2
  - wordpress = 2.0
  - wordpress = 2.0.1
  - wordpress = 2.0.2
  - wordpress = 2.0.3
  - wordpress = 2.0.4
  - wordpress = 2.0.5
  - wordpress = 2.0.6
  - wordpress = 2.0.7
  - wordpress = 2.0.8
  - wordpress = 2.0.9
  - wordpress = 2.0.10
  - wordpress = 2.0.11
  - wordpress = 2.1
  - wordpress = 2.1.1
  - wordpress = 2.1.2
  - wordpress = 2.1.3
  - wordpress = 2.2
  - wordpress = 2.2.1
  - wordpress = 2.2.2
  - wordpress = 2.2.3
  - wordpress = 2.3
  - wordpress = 2.3.1
  - wordpress = 2.3.2
  - wordpress = 2.3.3
  - wordpress = 2.5
  - wordpress = 2.5.1
  - wordpress = 2.6
  - wordpress = 2.6.1
  - wordpress = 2.6.2
  - wordpress = 2.6.3
  - wordpress = 2.6.5
  - wordpress = 2.7
  - wordpress = 2.7.1
  - wordpress = 2.8
  - wordpress = 2.8.1
  - wordpress = 2.8.2
  - wordpress = 2.8.3
  - wordpress = 2.8.4
  - wordpress = 2.8.5
  - wordpress = 2.8.6
  - wordpress = 2.9
  - wordpress = 2.9.1
  - wordpress = 2.9.2
  - wordpress = 3.0
  - wordpress = 3.0.1
  - wordpress = 3.0.2
  - wordpress = 3.0.3
  - wordpress = 3.0.4
  - wordpress = 3.0.5
  - wordpress = 3.0.6
  - wordpress = 3.1
  - wordpress = 3.1.1
  - wordpress = 3.1.2
  - wordpress = 3.1.3
  - wordpress = 3.1.4
  - wordpress = 3.2.1
  - wordpress = 3.3
published: '2012-01-30'
updated: '2026-11-03'
sourceUpdated: '2026-11-03T17:17:47.987'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2011-4899'
references:
  - url: 'http://archives.neohapsis.com/archives/bugtraq/2012-01/0150.html'
    label: cve@mitre.org
  - url: 'http://www.exploit-db.com/exploits/18417'
    label: cve@mitre.org
  - url: 'https://www.trustwave.com/spiderlabs/advisories/TWSL2012-002.txt'
    label: cve@mitre.org
  - url: 'http://archives.neohapsis.com/archives/bugtraq/2012-01/0150.html'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'http://www.exploit-db.com/exploits/18417'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://www.trustwave.com/spiderlabs/advisories/TWSL2012-002.txt'
    label: af854a3a-2127-422b-91ae-364da2661108
tags:
  - nvd
  - cve.org
  - exploit-available
exploitAvailable: true
ssvc:
  exploitation: poc
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2024-05-08T15:56:39.639939Z'
epss: 0.09023
epssPercentile: 0.953
exploits:
  exploitdb: true
  checkedAt: '2026-11-06T16:32:13.754Z'
ingestedAt: '2026-11-05T06:38:03.550Z'
---

## Overview

wp-admin/setup-config.php in the installation component in WordPress 3.3.1 and earlier does not ensure that the specified MySQL database service is appropriate, which allows remote attackers to configure an arbitrary database via the dbhost and dbname parameters, and subsequently conduct static code injection and cross-site scripting (XSS) attacks via (1) an HTTP request or (2) a MySQL query.  NOTE: the vendor disputes the significance of this issue; however, remote code execution makes the issue important in many realistic environments

## Affected

- `wordpress <= 3.3.1`
- `wordpress = 0.7`
- `wordpress = 0.71`
- `wordpress = 0.72`
- `wordpress = 0.711`
- `wordpress = 1.0`
- `wordpress = 1.0.1`
- `wordpress = 1.0.2`
- `wordpress = 1.2`
- `wordpress = 1.2.1`
- `wordpress = 1.2.2`
- `wordpress = 1.5`
- `wordpress = 1.5.1`
- `wordpress = 1.5.1.2`
- `wordpress = 1.5.1.3`
- `wordpress = 1.5.2`
- `wordpress = 2.0`
- `wordpress = 2.0.1`
- `wordpress = 2.0.2`
- `wordpress = 2.0.3`
- `wordpress = 2.0.4`
- `wordpress = 2.0.5`
- `wordpress = 2.0.6`
- `wordpress = 2.0.7`
- `wordpress = 2.0.8`
- `wordpress = 2.0.9`
- `wordpress = 2.0.10`
- `wordpress = 2.0.11`
- `wordpress = 2.1`
- `wordpress = 2.1.1`
- `wordpress = 2.1.2`
- `wordpress = 2.1.3`
- `wordpress = 2.2`
- `wordpress = 2.2.1`
- `wordpress = 2.2.2`
- `wordpress = 2.2.3`
- `wordpress = 2.3`
- `wordpress = 2.3.1`
- `wordpress = 2.3.2`
- `wordpress = 2.3.3`
- `wordpress = 2.5`
- `wordpress = 2.5.1`
- `wordpress = 2.6`
- `wordpress = 2.6.1`
- `wordpress = 2.6.2`
- `wordpress = 2.6.3`
- `wordpress = 2.6.5`
- `wordpress = 2.7`
- `wordpress = 2.7.1`
- `wordpress = 2.8`
- `wordpress = 2.8.1`
- `wordpress = 2.8.2`
- `wordpress = 2.8.3`
- `wordpress = 2.8.4`
- `wordpress = 2.8.5`
- `wordpress = 2.8.6`
- `wordpress = 2.9`
- `wordpress = 2.9.1`
- `wordpress = 2.9.2`
- `wordpress = 3.0`
- `wordpress = 3.0.1`
- `wordpress = 3.0.2`
- `wordpress = 3.0.3`
- `wordpress = 3.0.4`
- `wordpress = 3.0.5`
- `wordpress = 3.0.6`
- `wordpress = 3.1`
- `wordpress = 3.1.1`
- `wordpress = 3.1.2`
- `wordpress = 3.1.3`
- `wordpress = 3.1.4`
- `wordpress = 3.2.1`
- `wordpress = 3.3`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
