---
id: CVE-2016-20084
title: WordPress appointment-booking-calendar 1.1.24 Privilege Escalation XSS
summary: >-
  WordPress appointment-booking-calendar 1.1.24 contains multiple privilege
  escalation vulnerabilities that allow unauthenticated attackers to modify
  calendar settings and inject persistent cross-site scripting payloads through
  the admin.p…
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: dwbooster
product: Appointment Booking Calendar
affected:
  - appointment_booking_calendar <= 1.1.24
ssvc:
  exploitation: poc
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-06-15T22:02:39.894369Z'
exploitAvailable: true
published: '2026-06-15'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T21:14:58.960Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2016-20084'
references:
  - url: 'https://www.exploit-db.com/exploits/39341'
    label: ExploitDB-39341
  - url: 'https://wordpress.org/plugins/appointment-booking-calendar/'
    label: Product Reference
  - url: >-
      https://www.vulncheck.com/advisories/wordpress-appointment-booking-calendar-privilege-escalation-xss
    label: >-
      VulnCheck Advisory: WordPress appointment-booking-calendar 1.1.24
      Privilege Escalation XSS
tags:
  - cve.org
  - exploit-available
epss: 0.00245
epssPercentile: 0.15713
ingestedAt: '2026-11-03T08:39:35.529Z'
---

## Overview

WordPress appointment-booking-calendar 1.1.24 contains multiple privilege escalation vulnerabilities that allow unauthenticated attackers to modify calendar settings and inject persistent cross-site scripting payloads through the admin.php page parameters. Attackers can inject malicious JavaScript into the 'ict' and 'ics' options or the calendar 'name' parameter via GET requests to execute arbitrary scripts when the calendar is displayed or accessed in the administration interface.

## Affected

- `appointment_booking_calendar <= 1.1.24`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
