---
id: CVE-2017-1000469
aliases:
  - GHSA-96hw-v598-jvgh
  - PYSEC-2026-314
title: Cobbler vulnerable to arbitrary code execution
summary: Cobbler vulnerable to arbitrary code execution
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
vendor: cobbler
product: cobbler
ecosystem: pip
affected:
  - cobbler < 3.0.0
patched:
  - cobbler 3.0.0
published: '2022-05-14'
updated: '2026-10-27'
sourceUpdated: '2026-10-27T16:30:06.485593449Z'
source: OSV
sourceUrl: 'https://osv.dev/vulnerability/GHSA-96hw-v598-jvgh'
references:
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2017-1000469'
  - url: 'https://github.com/cobbler/cobbler/issues/1845'
  - url: >-
      https://github.com/cobbler/cobbler/commit/4b20397425a5d42a2d8927233654f4d7435bd4c2
  - url: 'https://github.com/cobbler/cobbler'
  - url: >-
      https://github.com/pypa/advisory-database/tree/main/vulns/cobbler/PYSEC-2026-314.yaml
  - url: 'https://pypi.org/project/cobbler'
  - url: 'https://github.com/advisories/GHSA-96hw-v598-jvgh'
tags:
  - osv
  - pip
  - ghsa
epss: 0.05556
epssPercentile: 0.9281
cwe:
  - CWE-20
ingestedAt: '2026-10-27T16:32:34.364Z'
---

## Overview

Cobbler version up to 2.8.2 is vulnerable to a command injection vulnerability in the "add repo" component resulting in arbitrary code execution as root user.

## Affected packages

- `cobbler < 3.0.0`

## Remediation

Upgrade to a patched release:

- `cobbler 3.0.0`
