---
id: CVE-2018-2811
title: >-
  Vulnerability in the Java SE component of Oracle Java SE (subcomponent:
  Install)
summary: >-
  Vulnerability in the Java SE component of Oracle Java SE (subcomponent:
  Install). Supported versions that are affected are Java SE: 8u162 and 10.
  Difficult to exploit vulnerability allows unauthenticated attacker with logon
  to the infras…
severity: high
cvss: 7.7
cvssVector: 'CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H'
vendor: oracle
product: jdk
affected:
  - jdk = 1.8.0
  - jdk = 10
  - jre = 1.8.0
  - jre = 10
  - enterprise_linux_server = 6.0
  - enterprise_linux_server = 7.0
  - enterprise_linux_workstation = 6.0
  - enterprise_linux_workstation = 7.0
  - struxureware_data_center_expert < 7.6.0
patched:
  - struxureware_data_center_expert 7.6.0
published: '2018-04-19'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T18:17:20.077'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2018-2811'
references:
  - url: >-
      http://www.oracle.com/technetwork/security-advisory/cpuapr2018-3678067.html
    label: secalert_us@oracle.com
  - url: 'http://www.securityfocus.com/bid/103810'
    label: secalert_us@oracle.com
  - url: 'http://www.securitytracker.com/id/1040697'
    label: secalert_us@oracle.com
  - url: 'https://access.redhat.com/errata/RHSA-2018:1202'
    label: secalert_us@oracle.com
  - url: 'https://access.redhat.com/errata/RHSA-2018:1204'
    label: secalert_us@oracle.com
  - url: >-
      https://help.ecostruxureit.com/display/public/UADCE725/Security+fixes+in+StruxureWare+Data+Center+Expert+v7.6.0
    label: secalert_us@oracle.com
  - url: 'https://security.gentoo.org/glsa/201903-14'
    label: secalert_us@oracle.com
  - url: 'https://security.netapp.com/advisory/ntap-20180419-0001/'
    label: secalert_us@oracle.com
  - url: >-
      http://www.oracle.com/technetwork/security-advisory/cpuapr2018-3678067.html
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'http://www.securityfocus.com/bid/103810'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'http://www.securitytracker.com/id/1040697'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://access.redhat.com/errata/RHSA-2018:1202'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://access.redhat.com/errata/RHSA-2018:1204'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: >-
      https://help.ecostruxureit.com/display/public/UADCE725/Security+fixes+in+StruxureWare+Data+Center+Expert+v7.6.0
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://security.gentoo.org/glsa/201903-14'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://security.netapp.com/advisory/ntap-20180419-0001/'
    label: af854a3a-2127-422b-91ae-364da2661108
tags:
  - nvd
  - cve.org
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-15T17:42:24.880409Z'
epss: 0.00494
epssPercentile: 0.42219
ingestedAt: '2026-10-15T18:23:58.394Z'
---

## Overview

Vulnerability in the Java SE component of Oracle Java SE (subcomponent: Install). Supported versions that are affected are Java SE: 8u162 and 10. Difficult to exploit vulnerability allows unauthenticated attacker with logon to the infrastructure where Java SE executes to compromise Java SE. Successful attacks require human interaction from a person other than the attacker and while the vulnerability is in Java SE, attacks may significantly impact additional products. Successful attacks of this vulnerability can result in takeover of Java SE. Note: Applies to installation process on client deployment of Java. CVSS 3.0 Base Score 7.7 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H).

## Affected

- `jdk = 1.8.0`
- `jdk = 10`
- `jre = 1.8.0`
- `jre = 10`
- `enterprise_linux_server = 6.0`
- `enterprise_linux_server = 7.0`
- `enterprise_linux_workstation = 6.0`
- `enterprise_linux_workstation = 7.0`
- `struxureware_data_center_expert < 7.6.0`

## Remediation

Upgrade past the affected range:

- `struxureware_data_center_expert 7.6.0`
