---
id: CVE-2018-7162
title: All versions of Node.js 9.x and 10.x are vulnerable and the severity is HIGH
summary: >-
  All versions of Node.js 9.x and 10.x are vulnerable and the severity is HIGH.
  An attacker can cause a denial of service (DoS) by causing a node process
  which provides an http server supporting TLS server to crash. This can be
  accomplishe…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H'
cwe:
  - CWE-20
  - CWE-416
vendor: nodejs
product: node.js
affected:
  - 'node.js >= 9.0.0, < 9.11.2'
  - 'node.js >= 10.0.0, < 10.4.1'
patched:
  - node.js 10.4.1
published: '2018-06-13'
updated: '2026-10-08'
sourceUpdated: '2026-10-08T22:16:47.950'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2018-7162'
references:
  - url: 'http://www.securityfocus.com/bid/104468'
    label: cve-request@iojs.org
  - url: 'https://nodejs.org/en/blog/vulnerability/june-2018-security-releases/'
    label: cve-request@iojs.org
  - url: 'https://security.gentoo.org/glsa/202003-48'
    label: cve-request@iojs.org
  - url: 'http://www.securityfocus.com/bid/104468'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://nodejs.org/en/blog/vulnerability/june-2018-security-releases/'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://security.gentoo.org/glsa/202003-48'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2018/cve-2018-7162.json
  - url: 'https://access.redhat.com/security/cve/CVE-2018-7162'
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=1591018'
  - url: 'https://www.cve.org/CVERecord?id=CVE-2018-7162'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2018-7162'
tags:
  - nvd
  - csaf
  - vex
  - red-hat
  - cve.org
epss: 0.06645
epssPercentile: 0.93837
ingestedAt: '2026-10-08T23:16:47.290Z'
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-08T21:11:51.399688Z'
---

## Overview

All versions of Node.js 9.x and 10.x are vulnerable and the severity is HIGH. An attacker can cause a denial of service (DoS) by causing a node process which provides an http server supporting TLS server to crash. This can be accomplished by sending duplicate/unexpected messages during the handshake. This vulnerability has been addressed by updating the TLS implementation.

## Affected

- `node.js >= 9.0.0, < 9.11.2`
- `node.js >= 10.0.0, < 10.4.1`

## Remediation

Upgrade past the affected range:

- `node.js 10.4.1`

## Vendor advisories

- **Red Hat VEX** · Moderate · updated 2026-10-09 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2018/cve-2018-7162.json)
