CVE-2020-1938Critical· 9.8▾ Hadal⚠ Exploited in the wildPoC availableWhen using the Apache JServ Protocol (AJP), care must be taken when trusting incoming connections to Apache Tomcat. Tomcat treats AJP connections as having higher trust than, for example, a similar HTTP connection. If such connections ar…
▾ Hadal zone — Critical and actively exploited (CISA KEV / 0day)
impact 53.9 · likelihood 19.9 · exploitation 25
A public proof-of-concept already exists for this vulnerability — see Exploit availability below.
Public exploit / PoC code seen in 4 sources. Availability, not in-the-wild use.
Exploit-prediction probability, daily snapshots since Aug 25.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via NVD
Federal remediation due Mar 17, 2022
Last analysed / modified upstream
99%
Exploit-DB · 40 GitHub repos · Metasploit ×1 · Nuclei ×1 (last check)
Added to the CISA catalog on Mar 3, 2022. Federal remediation due Mar 17, 2022. View catalog ↗
When using the Apache JServ Protocol (AJP), care must be taken when trusting incoming connections to Apache Tomcat. Tomcat treats AJP connections as having higher trust than, for example, a similar HTTP connection. If such connections are available to an attacker, they can be exploited in ways that may be surprising. In Apache Tomcat 9.0.0.M1 to 9.0.0.30, 8.5.0 to 8.5.50 and 7.0.0 to 7.0.99, Tomcat shipped with an AJP Connector enabled by default that listened on all configured IP addresses. It was expected (and recommended in the security guide) that this Connector would be disabled if not required. This vulnerability report identified a mechanism that allowed: - returning arbitrary files from anywhere in the web application - processing any file in the web application as a JSP Further, if the web application allowed file upload and stored those files within the web application (or the attacker was able to control the content of the web application by some other means) then this, along with the ability to process a file as a JSP, made remote code execution possible. It is important to note that mitigation is only required if an AJP port is accessible to untrusted users. Users wishing to take a defence-in-depth approach and block the vector that permits returning arbitrary files and execution as JSP may upgrade to Apache Tomcat 9.0.31, 8.5.51 or 7.0.100 or later. A number of changes were made to the default AJP Connector configuration in 9.0.31 to harden the default configuration. It is likely that users upgrading to 9.0.31, 8.5.51 or 7.0.100 or later will need to make small changes to their configurations.
geode = 1.12.0tomcat >= 7.0.0, < 7.0.100tomcat >= 8.5.0, < 8.5.51tomcat >= 9.0.0, < 9.0.31fedora = 30fedora = 31fedora = 32agile_engineering_data_management = 6.2.1.0agile_product_lifecycle_management = 9.3.3agile_product_lifecycle_management = 9.3.5agile_product_lifecycle_management = 9.3.6communications_element_manager = 8.1.1communications_element_manager = 8.2.0communications_element_manager = 8.2.1communications_instant_messaging_server = 10.0.1.4.0health_sciences_empirica_inspections = 1.0.1.2health_sciences_empirica_signal = 7.3.3hospitality_guest_access = 4.2.0hospitality_guest_access = 4.2.1instantis_enterprisetrack >= 17.1, <= 17.3mysql_enterprise_monitor <= 4.0.12mysql_enterprise_monitor >= 8.0.0, <= 8.0.20siebel_ui_framework <= 20.5transportation_management = 6.3.7workload_manager = 12.2.0.1workload_manager = 18cworkload_manager = 19cdebian_linux = 8.0debian_linux = 9.0debian_linux = 10.0leap = 15.1good_control <= 5.2.58.38workspaces_server = 7.0.1workspaces_server = 7.1.2workspaces_server = 8.1.0workspaces_server = 9.0data_availability_servicesoncommand_system_manager >= 3.0.0, <= 3.1.3Upgrade past the affected range:
tomcat 9.0.31Connected by shared product, vendor, weakness, or advisory.
CVE-2025-47410High· 8.8Apache Geode is vulnerable to CSRF attacks through GET requests to the Management and Monitoring REST API that could allow an attacker who has tricked a user into giving up their Geode session credentials to submit malicious commands on …
CVE-2026-104711Critical· 9.8Improper neutralization of special elements used in an expression language statement ('Expression Language Injection') vulnerability in Apache Struts
CVE-2026-63292High· 7.5Stack-based buffer overflow in mod_vhost_alias in Apache Software Foundation Apache HTTP Server through 2.4.68 on all platforms allows a remote client to cause a denial of service or potentially execute arbitrary code via an HTTP request…
CVE-2026-92415Medium· 5.3— Use of Externally-Controlled Input to Select Classes or Code vulnerability in Apache Jackrabbit's WebDAV/Davex client. A malicious WebDAV/DavEx server, or an attacker able to intercept the connection, can cause the client to instantia…
CVE-2026-92414Critical· 9.1: Session Fixation / Session Reuse across Users vulnerability in Apache Jackrabbit. Jackrabbit WebDAV server attaches a cached authenticated session on any Lock-Token/TransactionId/SubscriptionId/If-header field token match with no c…
CVE-2026-90466Medium· 6.5Path traversal of 'trusted_jar_paths' in Impala 4.5.2 allows an attacker-controlled JAR to be loaded via a relative path where the prefix matches a path specified in 'trusted_jar_paths'. The startup flag 'trusted_jar_paths' reference…