CVE-2021-3450High· 7.4▾ MidnightPoC availableThe X509_V_FLAG_X509_STRICT flag enables additional security checks of the certificates present in a certificate chain. It is not set by default. Starting from OpenSSL version 1.1.1h a check to disallow certificates in the chain that hav…
▾ Midnight zone — Critical, or high with PoC / in-the-wild
impact 40.7 · likelihood 3.7 · exploitation 12
A public proof-of-concept already exists for this vulnerability — see Exploit availability below.
Public exploit / PoC code seen in 1 source. Availability, not in-the-wild use.
Stakeholder-Specific Vulnerability Categorization from CISA's ADP record at CVE.org: whether exploitation is observed, whether an attack can be automated, and how much of the system is at stake.
Exploit-prediction probability, daily snapshots since Oct 8.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via NVD
Last analysed / modified upstream
18%
1 GitHub repo (last check)
The X509_V_FLAG_X509_STRICT flag enables additional security checks of the certificates present in a certificate chain. It is not set by default. Starting from OpenSSL version 1.1.1h a check to disallow certificates in the chain that have explicitly encoded elliptic curve parameters was added as an additional strict check. An error in the implementation of this check meant that the result of a previous check to confirm that certificates in the chain are valid CA certificates was overwritten. This effectively bypasses the check that non-CA certificates must not be able to issue other certificates. If a "purpose" has been configured then there is a subsequent opportunity for checks that the certificate is a valid CA. All of the named "purpose" values implemented in libcrypto perform this check. Therefore, where a purpose is set the certificate chain will still be rejected even when the strict flag has been used. A purpose is set by default in libssl client and server certificate verification routines, but it can be overridden or removed by an application. In order to be affected, an application must explicitly set the X509_V_FLAG_X509_STRICT verification flag and either not set a purpose for the certificate verification or, in the case of TLS client or server applications, override the default purpose. OpenSSL versions 1.1.1h and newer are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1k. OpenSSL 1.0.2 is not impacted by this issue. Fixed in OpenSSL 1.1.1k (Affected 1.1.1h-1.1.1j).
openssl >= 1.1.1h, < 1.1.1kfreebsd = 12.2santricity_smi-s_provider_firmwarestoragegrid_firmwarelinuxlinux = 17.0linux = 18.0linux = 19.0cloud_volumes_ontap_mediatoroncommand_workflow_automationontap_select_deploy_administration_utilitystoragegridfedora = 34nessus <= 8.13.1nessus_agent >= 8.2.1, <= 8.2.3nessus_network_monitor = 5.11.0nessus_network_monitor = 5.11.1nessus_network_monitor = 5.12.0nessus_network_monitor = 5.12.1nessus_network_monitor = 5.13.0commerce_guided_search = 11.3.2enterprise_manager_for_storage_management = 13.4.0.0graalvm = 19.3.5graalvm = 20.3.1.2graalvm = 21.0.0.2jd_edwards_enterpriseone_tools < 9.2.6.0jd_edwards_world_security = a9.4mysql_connectors <= 8.0.23mysql_enterprise_monitor <= 8.0.23mysql_server <= 5.7.33mysql_server >= 8.0.15, <= 8.0.23mysql_workbench <= 8.0.23peoplesoft_enterprise_peopletools >= 8.57, <= 8.59secure_backup < 18.1.0.1.0secure_global_desktop = 5.6weblogic_server = 12.2.1.4.0weblogic_server = 14.1.1.0.0web_gateway = 8.2.19web_gateway = 9.2.10web_gateway = 10.1.1web_gateway_cloud_service = 8.2.19web_gateway_cloud_service = 9.2.10web_gateway_cloud_service = 10.1.1sma100_firmware < 10.2.1.0-17svcapture_client < 3.6.24email_security < 10.0.11sonicos <= 7.0.1-r1456node.js >= 10.0.0, < 10.24.1node.js >= 12.0.0, < 12.22.1node.js >= 14.0.0, < 14.16.1node.js >= 15.0.0, < 15.14.0Upgrade past the affected range:
openssl 1.1.1kjd_edwards_enterpriseone_tools 9.2.6.0secure_backup 18.1.0.1.0sma100_firmware 10.2.1.0-17svcapture_client 3.6.24email_security 10.0.11node.js 15.14.0Connected by shared product, vendor, weakness, or advisory.
CVE-2022-0778High· 7.5The BN_mod_sqrt() function, which computes a modular square root, contains a bug that can cause it to loop forever for non-prime moduli
CVE-2021-3449Medium· 5.9An OpenSSL TLS server may crash if sent a maliciously crafted renegotiation ClientHello message from a client
CVE-2020-1967High· 7.5Server or client applications that call the SSL_check_chain() function during or after a TLS 1.3 handshake may crash due to a NULL pointer dereference as a result of incorrect handling of the "signature_algorithms_cert" TLS extension
CVE-2021-3711Critical· 9.8In order to decrypt SM2 encrypted data an application is expected to call the API function EVP_PKEY_decrypt()
CVE-2018-0737Medium· 5.9The OpenSSL RSA Key generation algorithm has been shown to be vulnerable to a cache timing side channel attack
CVE-2021-22926High· 7.5libcurl-using applications can ask for a specific client certificate to be used in a transfer