---
id: CVE-2022-2817
title: Use After Free in vim/vim
summary: Use After Free in GitHub repository vim/vim prior to 9.0.0213.
severity: high
cvss: 7.8
cvssVector: 'CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-416
vendor: vim
product: vim/vim
affected:
  - vim/vim >= unspecified < 9.0.0213
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-02T21:58:43.658685Z'
published: '2022-08-15'
updated: '2026-11-02'
sourceUpdated: '2026-11-02T21:58:59.898Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2022-2817'
references:
  - url: 'https://huntr.dev/bounties/a7b7d242-3d88-4bde-a681-6c986aff886f'
  - url: 'https://github.com/vim/vim/commit/249e1b903a9c0460d618f6dcc59aeb8c03b24b20'
  - url: >-
      https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CHFAR6OY6G77M6GXCJT75A4KITLNR6GO/
    label: FEDORA-2022-6f5e420e52
  - url: 'https://security.gentoo.org/glsa/202305-16'
    label: GLSA-202305-16
tags:
  - cve.org
epss: 0.00535
epssPercentile: 0.45401
ingestedAt: '2026-11-05T19:30:42.861Z'
---

## Overview

Use After Free in GitHub repository vim/vim prior to 9.0.0213.

## Affected

- `vim/vim >= unspecified < 9.0.0213`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
