---
id: CVE-2022-2889
title: Use After Free in vim/vim
summary: Use After Free in GitHub repository vim/vim prior to 9.0.0225.
severity: high
cvss: 7.8
cvssVector: 'CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-416
vendor: vim
product: vim/vim
affected:
  - vim/vim >= unspecified < 9.0.0225
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-02T22:00:45.871196Z'
published: '2022-08-19'
updated: '2026-11-02'
sourceUpdated: '2026-11-02T22:00:52.191Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2022-2889'
references:
  - url: 'https://huntr.dev/bounties/d1ac9817-825d-49ce-b514-1d5b12b6bdaa'
  - url: 'https://github.com/vim/vim/commit/91c7cbfe31bbef57d5fcf7d76989fc159f73ef15'
  - url: >-
      https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/C72HDIMR3KTTAO7QGTXWUMPBNFUFIBRD/
    label: FEDORA-2022-3b33d04743
  - url: 'https://security.gentoo.org/glsa/202305-16'
    label: GLSA-202305-16
tags:
  - cve.org
epss: 0.00534
epssPercentile: 0.4529
ingestedAt: '2026-11-05T19:30:42.863Z'
---

## Overview

Use After Free in GitHub repository vim/vim prior to 9.0.0225.

## Affected

- `vim/vim >= unspecified < 9.0.0225`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
