---
id: CVE-2022-4139
title: >-
  An incorrect TLB flush issue was found in the Linux kernel’s GPU i915 kernel
  driver, potentially leading to random memory corruption or data leaks
summary: >-
  An incorrect TLB flush issue was found in the Linux kernel’s GPU i915 kernel
  driver, potentially leading to random memory corruption or data leaks. This
  flaw could allow a local user to crash the system or escalate their privileges
  on th…
severity: high
cvss: 7.8
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-281
  - CWE-401
vendor: linux
product: linux_kernel
affected:
  - 'linux_kernel >= 5.4, < 5.4.226'
  - 'linux_kernel >= 5.5, < 5.10.157'
  - 'linux_kernel >= 5.11, < 5.15.81'
  - 'linux_kernel >= 5.16, < 6.0.11'
  - linux_kernel = 6.1
patched:
  - linux_kernel 6.0.11
published: '2023-01-27'
updated: '2026-10-14'
sourceUpdated: '2026-10-14T14:17:28.330'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2022-4139'
references:
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2147572'
    label: secalert@redhat.com
  - url: 'https://security.netapp.com/advisory/ntap-20230309-0004/'
    label: secalert@redhat.com
  - url: 'https://www.openwall.com/lists/oss-security/2022/11/30/1'
    label: secalert@redhat.com
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2147572'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://security.netapp.com/advisory/ntap-20230309-0004/'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://www.openwall.com/lists/oss-security/2022/11/30/1'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://cert-portal.siemens.com/productcert/html/ssa-794697.html'
    label: 0b142b55-0307-4c5a-b3c9-f314f3fb7c5e
tags:
  - nvd
  - cve.org
epss: 0.0026
epssPercentile: 0.1758
ingestedAt: '2026-10-14T15:36:13.929Z'
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2025-03-28T15:43:18.557475Z'
---

## Overview

An incorrect TLB flush issue was found in the Linux kernel’s GPU i915 kernel driver, potentially leading to random memory corruption or data leaks. This flaw could allow a local user to crash the system or escalate their privileges on the system.

## Affected

- `linux_kernel >= 5.4, < 5.4.226`
- `linux_kernel >= 5.5, < 5.10.157`
- `linux_kernel >= 5.11, < 5.15.81`
- `linux_kernel >= 5.16, < 6.0.11`
- `linux_kernel = 6.1`

## Remediation

Upgrade past the affected range:

- `linux_kernel 6.0.11`
