---
id: CVE-2022-46421
aliases:
  - GHSA-rc58-qr9j-cpgw
  - PYSEC-2026-274
title: Apache Airflow Hive Provider vulnerable to Command Injection
summary: Apache Airflow Hive Provider vulnerable to Command Injection
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
vendor: apache-airflow-providers-apache-hive
product: apache-airflow-providers-apache-hive
ecosystem: pip
affected:
  - apache-airflow-providers-apache-hive < 5.0.0
patched:
  - apache-airflow-providers-apache-hive 5.0.0
published: '2022-12-20'
updated: '2026-10-26'
sourceUpdated: '2026-10-26T21:30:04.166041841Z'
source: OSV
sourceUrl: 'https://osv.dev/vulnerability/GHSA-rc58-qr9j-cpgw'
references:
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2022-46421'
  - url: 'https://github.com/apache/airflow/pull/28101'
  - url: 'https://github.com/apache/airflow'
  - url: >-
      https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow-providers-apache-hive/PYSEC-2026-274.yaml
  - url: 'https://lists.apache.org/thread/09twdoyoybldlfj5gvk0qswtofh0rmp4'
  - url: 'https://pypi.org/project/apache-airflow-providers-apache-hive'
  - url: 'https://github.com/advisories/GHSA-rc58-qr9j-cpgw'
tags:
  - osv
  - pip
  - ghsa
epss: 0.03286
epssPercentile: 0.88404
cwe:
  - CWE-77
ingestedAt: '2026-10-27T16:11:58.766Z'
---

## Overview

Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache Software Foundation Apache Airflow Hive Provider.This issue affects Apache Airflow Hive Provider before 5.0.0.

## Affected packages

- `apache-airflow-providers-apache-hive < 5.0.0`

## Remediation

Upgrade to a patched release:

- `apache-airflow-providers-apache-hive 5.0.0`
