---
id: CVE-2022-50059
title: |-
  In the Linux kernel, the following vulnerability has been resolved:

  ceph: don't leak snap_rwsem in handle_cap_grant

  When handle_cap_grant is called on an IMPORT op, then the snap_rwsem is
  held and the function is expected to release it…
summary: |-
  In the Linux kernel, the following vulnerability has been resolved:

  ceph: don't leak snap_rwsem in handle_cap_grant

  When handle_cap_grant is called on an IMPORT op, then the snap_rwsem is
  held and the function is expected to release it…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H'
vendor: linux
product: linux_kernel
affected:
  - 'linux_kernel >= 5.8, < 5.10.138'
  - 'linux_kernel >= 5.11, < 5.15.63'
  - 'linux_kernel >= 5.16, < 5.19.4'
patched:
  - linux_kernel 5.19.4
published: '2025-06-18'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T22:17:27.010'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2022-50059'
references:
  - url: 'https://git.kernel.org/stable/c/58dd4385577ed7969b80cdc9e2a31575aba6c712'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/a090cc69699ec2d11b5e34cee8c61f0d4b0068cb'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/aee18421bda6bf12a7cba6a3d7751c0e1cfd0094'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/f546faa216d0f53a42ca73ba1fd8c48765b22d77'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
tags:
  - nvd
  - cve.org
epss: 0.00443
epssPercentile: 0.38318
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-15T21:30:09.490540Z'
ingestedAt: '2026-10-15T21:45:11.284Z'
---

## Overview

In the Linux kernel, the following vulnerability has been resolved:

ceph: don't leak snap_rwsem in handle_cap_grant

When handle_cap_grant is called on an IMPORT op, then the snap_rwsem is
held and the function is expected to release it before returning. It
currently fails to do that in all cases which could lead to a deadlock.

## Affected

- `linux_kernel >= 5.8, < 5.10.138`
- `linux_kernel >= 5.11, < 5.15.63`
- `linux_kernel >= 5.16, < 5.19.4`

## Remediation

Upgrade past the affected range:

- `linux_kernel 5.19.4`
