---
id: CVE-2023-0507
title: Grafana is an open-source platform for monitoring and observability
summary: >-
  Grafana is an open-source platform for monitoring and observability. 


  Starting with the 8.1 branch, Grafana had a stored XSS vulnerability affecting
  the core plugin GeoMap. 


  The stored XSS vulnerability was possible due to map attribut…
severity: high
cvss: 7.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N'
cwe:
  - CWE-79
vendor: grafana
product: grafana
affected:
  - 'grafana >= 8.1.0, < 8.5.21'
  - 'grafana >= 9.2.0, < 9.2.13'
  - 'grafana >= 9.3.0, < 9.3.8'
patched:
  - grafana 9.3.8
published: '2023-03-01'
updated: '2026-11-03'
sourceUpdated: '2026-11-03T22:17:11.460'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2023-0507'
references:
  - url: 'https://grafana.com/security/security-advisories/cve-2023-0507/'
    label: security@grafana.com
  - url: 'https://security.netapp.com/advisory/ntap-20230413-0001/'
    label: security@grafana.com
  - url: 'https://grafana.com/security/security-advisories/cve-2023-0507/'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://security.netapp.com/advisory/ntap-20230413-0001/'
    label: af854a3a-2127-422b-91ae-364da2661108
tags:
  - nvd
  - cve.org
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-01-28T04:55:40.468957Z'
epss: 0.1546
epssPercentile: 0.96812
ingestedAt: '2026-11-05T06:38:03.560Z'
---

## Overview

Grafana is an open-source platform for monitoring and observability. 

Starting with the 8.1 branch, Grafana had a stored XSS vulnerability affecting the core plugin GeoMap. 

The stored XSS vulnerability was possible due to map attributions weren't properly sanitized and allowed arbitrary JavaScript to be executed in the context of the currently authorized user of the Grafana instance. 

An attacker needs to have the Editor role in order to change a panel to include a map attribution containing JavaScript. 

This means that vertical privilege escalation is possible, where a user with Editor role can change to a known password for a user having Admin role if the user with Admin role executes malicious JavaScript viewing a dashboard. 

Users may upgrade to version 8.5.21, 9.2.13 and 9.3.8 to receive a fix.

## Affected

- `grafana >= 8.1.0, < 8.5.21`
- `grafana >= 9.2.0, < 9.2.13`
- `grafana >= 9.3.0, < 9.3.8`

## Remediation

Upgrade past the affected range:

- `grafana 9.3.8`
