CVE-2023-3399High· 8.5▾ MidnightPoC availableAn issue has been discovered in GitLab EE affecting all versions starting from 11.6 before 16.3.6, all versions starting from 16.4 before 16.4.2, all versions starting from 16.5 before 16.5.1. It was possible for an unauthorised project …
▾ Midnight zone — Critical, or high with PoC / in-the-wild
impact 46.8 · likelihood 0.1 · exploitation 12
A public proof-of-concept already exists for this vulnerability — see Exploit availability below.
Stakeholder-Specific Vulnerability Categorization from CISA's ADP record at CVE.org: whether exploitation is observed, whether an attack can be automated, and how much of the system is at stake. The CVSS score shown above comes from the assigning CNA record, not NVD.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via CVEORG
Last analysed / modified upstream
0.5%
An issue has been discovered in GitLab EE affecting all versions starting from 11.6 before 16.3.6, all versions starting from 16.4 before 16.4.2, all versions starting from 16.5 before 16.5.1. It was possible for an unauthorised project or group member to read the CI/CD variables using the custom project templates.
GitLab >= 11.6 < 16.3.6GitLab >= 16.4 < 16.4.2GitLab >= 16.5 < 16.5.1Upgrade to versions 16.5.1, 16.4.2, 16.3.6 or above.
Connected by shared product, vendor, weakness, or advisory.
CVE-2026-105777Medium· 4.3Insertion of Sensitive Information Into Sent Data in GitLab
CVE-2023-5831Low· 3.7Insertion of Sensitive Information Into Sent Data in GitLab
CVE-2026-82837Medium· 5.3GitLab has remediated an issue in GitLab CE/EE affecting all versions from 10.1.0 before 19.1.8, 19.2 before 19.2.6, and 19.3 before 19.3.2 that certain conditions could have allowed an authenticated user to access sensitive credentials …
CVE-2026-110264Critical· 10.0Integer Overflow or Wraparound in GitLab
CVE-2023-4379High· 8.1Incorrect Authorization in GitLab
CVE-2026-97229Critical· 10.0GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary cod…