---
id: CVE-2023-3611
title: >-
  An out-of-bounds write vulnerability in the Linux kernel's net/sched: sch_qfq
  component can be exploited to achieve local privilege escalation.


  The qfq_change_agg() function in net/sched/sch_qfq.c allows an out-of-bounds
  write because l…
summary: >-
  An out-of-bounds write vulnerability in the Linux kernel's net/sched: sch_qfq
  component can be exploited to achieve local privilege escalation.


  The qfq_change_agg() function in net/sched/sch_qfq.c allows an out-of-bounds
  write because l…
severity: high
cvss: 7.8
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-787
vendor: linux
product: linux_kernel
affected:
  - 'linux_kernel >= 3.8, < 4.14.322'
  - 'linux_kernel >= 4.15, < 4.19.291'
  - 'linux_kernel >= 4.20, < 5.4.253'
  - 'linux_kernel >= 5.5, < 5.10.188'
  - 'linux_kernel >= 5.11, < 5.15.121'
  - 'linux_kernel >= 5.16, < 6.1.40'
  - 'linux_kernel >= 6.2, < 6.4.5'
  - linux_kernel = 6.5
  - debian_linux = 10.0
  - debian_linux = 11.0
  - debian_linux = 12.0
patched:
  - linux_kernel 6.4.5
published: '2023-07-21'
updated: '2026-10-14'
sourceUpdated: '2026-10-14T22:17:15.320'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2023-3611'
references:
  - url: >-
      https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=3e337087c3b5805fe0b8a46ba622a962880b5d64
    label: cve-coordination@google.com
  - url: 'https://kernel.dance/3e337087c3b5805fe0b8a46ba622a962880b5d64'
    label: cve-coordination@google.com
  - url: 'https://lists.debian.org/debian-lts-announce/2023/10/msg00027.html'
    label: cve-coordination@google.com
  - url: 'https://lists.debian.org/debian-lts-announce/2024/01/msg00004.html'
    label: cve-coordination@google.com
  - url: 'https://security.netapp.com/advisory/ntap-20230908-0002/'
    label: cve-coordination@google.com
  - url: 'https://www.debian.org/security/2023/dsa-5480'
    label: cve-coordination@google.com
  - url: 'https://www.debian.org/security/2023/dsa-5492'
    label: cve-coordination@google.com
  - url: >-
      https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=3e337087c3b5805fe0b8a46ba622a962880b5d64
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://kernel.dance/3e337087c3b5805fe0b8a46ba622a962880b5d64'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://lists.debian.org/debian-lts-announce/2023/10/msg00027.html'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://lists.debian.org/debian-lts-announce/2024/01/msg00004.html'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://security.netapp.com/advisory/ntap-20230908-0002/'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://www.debian.org/security/2023/dsa-5480'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://www.debian.org/security/2023/dsa-5492'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://cert-portal.siemens.com/productcert/html/ssa-398330.html'
    label: 0b142b55-0307-4c5a-b3c9-f314f3fb7c5e
  - url: 'https://cert-portal.siemens.com/productcert/html/ssa-769027.html'
    label: 0b142b55-0307-4c5a-b3c9-f314f3fb7c5e
  - url: 'https://cert-portal.siemens.com/productcert/html/ssa-794697.html'
    label: 0b142b55-0307-4c5a-b3c9-f314f3fb7c5e
  - url: 'https://cert-portal.siemens.com/productcert/html/ssa-806742.html'
    label: 0b142b55-0307-4c5a-b3c9-f314f3fb7c5e
  - url: 'https://cert-portal.siemens.com/productcert/html/ssa-831302.html'
    label: 0b142b55-0307-4c5a-b3c9-f314f3fb7c5e
tags:
  - nvd
  - cve.org
epss: 0.00293
epssPercentile: 0.21712
ingestedAt: '2026-10-14T23:00:01.999Z'
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2024-09-27T13:33:11.602895Z'
---

## Overview

An out-of-bounds write vulnerability in the Linux kernel's net/sched: sch_qfq component can be exploited to achieve local privilege escalation.

The qfq_change_agg() function in net/sched/sch_qfq.c allows an out-of-bounds write because lmax is updated according to packet sizes without bounds checks.

We recommend upgrading past commit 3e337087c3b5805fe0b8a46ba622a962880b5d64.

## Affected

- `linux_kernel >= 3.8, < 4.14.322`
- `linux_kernel >= 4.15, < 4.19.291`
- `linux_kernel >= 4.20, < 5.4.253`
- `linux_kernel >= 5.5, < 5.10.188`
- `linux_kernel >= 5.11, < 5.15.121`
- `linux_kernel >= 5.16, < 6.1.40`
- `linux_kernel >= 6.2, < 6.4.5`
- `linux_kernel = 6.5`
- `debian_linux = 10.0`
- `debian_linux = 11.0`
- `debian_linux = 12.0`

## Remediation

Upgrade past the affected range:

- `linux_kernel 6.4.5`
