CVE-2023-37415High· 8.8▾ TwilightApache Airflow Apache Hive Provider Improper Input Validation vulnerability
▾ Twilight zone — High severity, or a signal on a lesser flaw
impact 48.4 · likelihood 0.3 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Exploit-prediction probability, daily snapshots since Aug 1.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via OSV
Last analysed / modified upstream
1.6%
Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Apache Hive Provider.
Patching on top of CVE-2023-35797 Before 6.1.2 the proxy_user option can also inject semicolon.
This issue affects Apache Airflow Apache Hive Provider: before 6.1.2.
It is recommended updating provider version to 6.1.2 in order to avoid this vulnerability.
apache-airflow-providers-apache-hive < 6.1.2Upgrade to a patched release:
apache-airflow-providers-apache-hive 6.1.2Connected by shared product, vendor, weakness, or advisory.
CVE-2023-35797Critical· 9.8Apache Airflow Hive Provider Beeline remote code execution with Principal
CVE-2023-25696Critical· 9.8Apache Airflow Hive Provider Improper Input Validation vulnerability
CVE-2023-28706Critical· 9.8Apache Airflow Hive Provider vulnerable to code injection
CVE-2022-46421Critical· 9.8Apache Airflow Hive Provider vulnerable to Command Injection
CVE-2022-41131High· 7.8OS Command Injection in Apache Airflow