CVE-2023-46246Medium· 4.0▾ SunlitVim is an improved version of the good old UNIX editor Vi. Heap-use-after-free in memory allocated in the function `ga_grow_inner` in in the file `src/alloc.c` at line 748, which is freed in the file `src/ex_docmd.c` in the function `do_…
▾ Sunlit zone — Low / medium · no exploitation signal
impact 22 · likelihood 0.1 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Exploit-prediction probability, daily snapshots since Aug 1.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via NVD
Last analysed / modified upstream
0.4%
0.4% → 0.4%
Vim is an improved version of the good old UNIX editor Vi. Heap-use-after-free in memory allocated in the function ga_grow_inner in in the file src/alloc.c at line 748, which is freed in the file src/ex_docmd.c in the function do_cmdline at line 1010 and then used again in src/cmdhist.c at line 759. When using the :history command, it's possible that the provided argument overflows the accepted value. Causing an Integer Overflow and potentially later an use-after-free. This vulnerability has been patched in version 9.0.2068.
vim < 9.0.2068Upgrade past the affected range:
vim 9.0.2068Connected by shared product, vendor, weakness, or advisory.
CVE-2022-2946High· 7.8Use After Free in GitHub repository vim/vim prior to 9.0.0246.
CVE-2022-2042High· 7.8Use After Free in GitHub repository vim/vim prior to 8.2.
CVE-2022-1616High· 7.8Use after free in append_command in GitHub repository vim/vim prior to 8.2.4895
CVE-2022-2345High· 7.8Use After Free in GitHub repository vim/vim prior to 9.0.0046.
CVE-2022-2285High· 7.8Integer Overflow or Wraparound in GitHub repository vim/vim prior to 9.0.
CVE-2021-3974High· 7.8vim is vulnerable to Use After Free