CVE-2023-5009High· 8.2▾ TwilightAn issue has been discovered in GitLab EE affecting all versions starting from 13.12 before 16.2.7, all versions starting from 16.3 before 16.3.4. It was possible for an attacker to run pipeline jobs as an arbitrary user via scheduled se…
▾ Twilight zone — High severity, or a signal on a lesser flaw
impact 45.1 · likelihood 1.9 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Stakeholder-Specific Vulnerability Categorization from CISA's ADP record at CVE.org: whether exploitation is observed, whether an attack can be automated, and how much of the system is at stake. The CVSS score shown above comes from the assigning CNA record, not NVD.
Exploit-prediction probability, daily snapshots since Oct 28.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via CVEORG
Last analysed / modified upstream
9.7%
An issue has been discovered in GitLab EE affecting all versions starting from 13.12 before 16.2.7, all versions starting from 16.3 before 16.3.4. It was possible for an attacker to run pipeline jobs as an arbitrary user via scheduled security scan policies. This was a bypass of CVE-2023-3932 showing additional impact.
GitLab >= 13.12 < 16.2.7GitLab >= 16.3 < 16.3.4Upgrade to versions 16.2.7, 16.3.4 or above For those users unable to upgrade for those versions, you can mitigate the vulnerability by having at most one of those two features turned on at one time: - Direct transfers - Security policies
Connected by shared product, vendor, weakness, or advisory.
CVE-2026-103515Low· 2.7Incorrect Authorization in GitLab
CVE-2026-16255Medium· 5.9Incorrect Authorization in GitLab
CVE-2026-12664Medium· 6.8Incorrect Authorization in GitLab
CVE-2023-4379High· 8.1Incorrect Authorization in GitLab
CVE-2026-9268Low· 2.7GitLab has remediated an issue in GitLab EE affecting all versions from 13.6 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an authenticated user with limited permissions to m…
CVE-2026-92528Medium· 4.2GitLab has remediated an issue in GitLab EE affecting all versions from 16.11 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an authenticated user to approve a merge request d…