---
id: CVE-2023-53643
title: |-
  In the Linux kernel, the following vulnerability has been resolved:

  nvme-tcp: don't access released socket during error recovery

  While the error recovery work is temporarily failing reconnect attempts,
  running the 'nvme list' command c…
summary: |-
  In the Linux kernel, the following vulnerability has been resolved:

  nvme-tcp: don't access released socket during error recovery

  While the error recovery work is temporarily failing reconnect attempts,
  running the 'nvme list' command c…
severity: high
cvss: 7.8
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-476
vendor: linux
product: linux_kernel
affected:
  - 'linux_kernel >= 6.1, < 6.1.18'
  - 'linux_kernel >= 6.2, < 6.2.5'
patched:
  - linux_kernel 6.2.5
published: '2025-10-07'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T22:17:45.263'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2023-53643'
references:
  - url: 'https://git.kernel.org/stable/c/76d54bf20cdcc1ed7569a89885e09636e9a8d71d'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/d82f762db4776fa11de88018f0f5de2d5db72a72'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/fe2d9e54165dadaa0d0cc3355c0be9c3e129fa0d'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
tags:
  - nvd
  - cve.org
epss: 0.00166
epssPercentile: 0.05745
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-15T21:36:13.085900Z'
ingestedAt: '2026-10-15T22:48:25.413Z'
---

## Overview

In the Linux kernel, the following vulnerability has been resolved:

nvme-tcp: don't access released socket during error recovery

While the error recovery work is temporarily failing reconnect attempts,
running the 'nvme list' command causes a kernel NULL pointer dereference
by calling getsockname() with a released socket.

During error recovery work, the nvme tcp socket is released and a new one
created, so it is not safe to access the socket without proper check.

## Affected

- `linux_kernel >= 6.1, < 6.1.18`
- `linux_kernel >= 6.2, < 6.2.5`

## Remediation

Upgrade past the affected range:

- `linux_kernel 6.2.5`
