---
id: CVE-2023-54285
title: |-
  In the Linux kernel, the following vulnerability has been resolved:

  iomap: Fix possible overflow condition in iomap_write_delalloc_scan

  folio_next_index() returns an unsigned long value which left shifted
  by PAGE_SHIFT could possibly c…
summary: |-
  In the Linux kernel, the following vulnerability has been resolved:

  iomap: Fix possible overflow condition in iomap_write_delalloc_scan

  folio_next_index() returns an unsigned long value which left shifted
  by PAGE_SHIFT could possibly c…
severity: high
cvss: 7.1
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H'
cwe:
  - CWE-787
vendor: linux
product: linux_kernel
affected:
  - 'linux_kernel >= 6.1.92, < 6.1.162'
  - 'linux_kernel >= 6.2, < 6.5.5'
patched:
  - linux_kernel 6.5.5
published: '2025-12-30'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T22:17:57.430'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2023-54285'
references:
  - url: 'https://git.kernel.org/stable/c/0c6cf409093f307ee05114f834516730c0da5b21'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/5c281b0c5d18c8eeb1cfd5023f4adb153e6d1240'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/eee2d2e6ea5550118170dbd5bb1316ceb38455fb'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
tags:
  - nvd
  - cve.org
epss: 0.00179
epssPercentile: 0.07424
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-15T21:40:04.519325Z'
ingestedAt: '2026-10-15T22:48:25.437Z'
---

## Overview

In the Linux kernel, the following vulnerability has been resolved:

iomap: Fix possible overflow condition in iomap_write_delalloc_scan

folio_next_index() returns an unsigned long value which left shifted
by PAGE_SHIFT could possibly cause an overflow on 32-bit system. Instead
use folio_pos(folio) + folio_size(folio), which does this correctly.

## Affected

- `linux_kernel >= 6.1.92, < 6.1.162`
- `linux_kernel >= 6.2, < 6.5.5`

## Remediation

Upgrade past the affected range:

- `linux_kernel 6.5.5`
