---
id: CVE-2023-54408
title: >-
  Frappe before 13.52.0 and 14.x before 14.31.0 contains an HTML injection
  vulnerability caused by weak escaping of user-supplied content rendered in
  pages
summary: >-
  Frappe before 13.52.0 and 14.x before 14.31.0 contains an HTML injection
  vulnerability caused by weak escaping of user-supplied content rendered in
  pages. Attackers can submit crafted HTML that bypasses the insufficient
  escaping and is r…
severity: medium
cvss: 6.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
published: '2026-10-12'
updated: '2026-10-13'
sourceUpdated: '2026-10-13T17:17:13.600'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2023-54408'
references:
  - url: 'https://github.com/frappe/frappe/security/advisories/GHSA-4jj9-5vgc-gc4j'
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/frappe-before-14.31.0-html-injection-via-weak-escaping
    label: disclosure@vulncheck.com
tags:
  - nvd
  - cve.org
epss: 0.00204
epssPercentile: 0.10301
ingestedAt: '2026-10-13T00:09:02.606Z'
vendor: frappe
product: frappe
affected:
  - frappe < 13.52.0
  - frappe >= 14.0.0-beta.1 < 14.31.0
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-13T16:22:00.814482Z'
---

## Overview

Frappe before 13.52.0 and 14.x before 14.31.0 contains an HTML injection vulnerability caused by weak escaping of user-supplied content rendered in pages. Attackers can submit crafted HTML that bypasses the insufficient escaping and is rendered in the browsers of users who view it, enabling cross-site scripting.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
