---
id: CVE-2023-54409
title: >-
  Frappe before 13.46.1 and 14.x before 14.20.0 contains a cross-site scripting
  vulnerability because the html2text function weakly sanitizes user input
summary: >-
  Frappe before 13.46.1 and 14.x before 14.20.0 contains a cross-site scripting
  vulnerability because the html2text function weakly sanitizes user input.
  Authenticated attackers can supply crafted HTML that is insufficiently
  sanitized by h…
severity: medium
cvss: 4.8
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:N/A:N'
cwe:
  - CWE-80
published: '2026-10-12'
updated: '2026-10-13'
sourceUpdated: '2026-10-13T14:17:16.847'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2023-54409'
references:
  - url: 'https://github.com/frappe/frappe/security/advisories/GHSA-wp7j-3w22-93j6'
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/frappe-before-13.46.1-xss-via-html2text-weak-sanitization
    label: disclosure@vulncheck.com
tags:
  - nvd
  - cve.org
epss: 0.00224
epssPercentile: 0.12888
ingestedAt: '2026-10-13T00:09:02.606Z'
vendor: frappe
product: frappe
affected:
  - frappe < 13.46.1
  - frappe >= 14.0.0-beta.1 < 14.20.0
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-13T13:33:04.870394Z'
---

## Overview

Frappe before 13.46.1 and 14.x before 14.20.0 contains a cross-site scripting vulnerability because the html2text function weakly sanitizes user input. Authenticated attackers can supply crafted HTML that is insufficiently sanitized by html2text, executing scripts in the browsers of users who view the rendered content.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
