---
id: CVE-2024-2195
aliases:
  - GHSA-mxvw-cj37-8g2h
  - PYSEC-2026-260
title: Aim Web API vulnerable to Remote Code Execution
summary: Aim Web API vulnerable to Remote Code Execution
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
vendor: aim
product: aim
ecosystem: pip
affected:
  - 'aim >= 3.0.0, <= 3.25.0'
published: '2024-04-10'
updated: '2026-10-27'
sourceUpdated: '2026-10-27T15:30:04.343940178Z'
source: OSV
sourceUrl: 'https://osv.dev/vulnerability/GHSA-mxvw-cj37-8g2h'
references:
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2024-2195'
  - url: 'https://github.com/aimhubio/aim'
  - url: >-
      https://github.com/pypa/advisory-database/tree/main/vulns/aim/PYSEC-2026-260.yaml
  - url: 'https://huntr.com/bounties/22f2355e-b875-4c01-b454-327e5951c018'
  - url: 'https://pypi.org/project/aim'
  - url: 'https://github.com/advisories/GHSA-mxvw-cj37-8g2h'
tags:
  - osv
  - pip
  - ghsa
epss: 0.01815
epssPercentile: 0.78567
cwe:
  - CWE-94
ingestedAt: '2026-09-12T03:13:01.713Z'
---

## Overview

A critical Remote Code Execution (RCE) vulnerability was identified in the aimhubio/aim project, specifically within the `/api/runs/search/run/` endpoint, affecting versions >= 3.0.0. The vulnerability resides in the `run_search_api` function of the `aim/web/api/runs/views.py` file, where improper restriction of user access to the `RunView` object allows for the execution of arbitrary code via the `query` parameter. This issue enables attackers to execute arbitrary commands on the server, potentially leading to full system compromise.

## Affected packages

- `aim >= 3.0.0, <= 3.25.0`

## Remediation

Refer to the advisory for the patched release.
