---
id: CVE-2024-23730
aliases:
  - GHSA-297x-2qf3-jrj3
  - PYSEC-2026-393
title: Unsafe yaml deserialization in llama-hub
summary: Unsafe yaml deserialization in llama-hub
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
vendor: llama-hub
product: llama-hub
ecosystem: pip
affected:
  - llama-hub < 0.0.67
patched:
  - llama-hub 0.0.67
published: '2024-01-21'
updated: '2026-10-27'
sourceUpdated: '2026-10-27T17:45:03.980436464Z'
source: OSV
sourceUrl: 'https://osv.dev/vulnerability/GHSA-297x-2qf3-jrj3'
references:
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2024-23730'
  - url: >-
      https://github.com/run-llama/llama-hub/pull/841/commits/9dc9c21a5c6d0226d1d2101c3121d4f085743d52
  - url: >-
      https://github.com/run-llama/llama-hub/commit/c01416e737c7747a213a79881b8308c41d043515
  - url: >-
      https://github.com/pypa/advisory-database/tree/main/vulns/llama-hub/PYSEC-2026-393.yaml
  - url: 'https://github.com/run-llama/llama-hub'
  - url: 'https://github.com/run-llama/llama-hub/blob/v0.0.67/CHANGELOG.md'
  - url: 'https://github.com/run-llama/llama-hub/releases/tag/v0.0.67'
  - url: 'https://pypi.org/project/llama-hub'
  - url: 'https://github.com/advisories/GHSA-297x-2qf3-jrj3'
tags:
  - osv
  - pip
  - ghsa
epss: 0.01202
epssPercentile: 0.68062
cwe:
  - CWE-502
ingestedAt: '2026-10-27T17:33:23.766Z'
---

## Overview

The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow attackers to execute arbitrary code because safe_load is not used for YAML.

## Affected packages

- `llama-hub < 0.0.67`

## Remediation

Upgrade to a patched release:

- `llama-hub 0.0.67`
