---
id: CVE-2024-24974
title: >-
  The interactive service in OpenVPN 2.6.9 and earlier allows the OpenVPN
  service pipe to be accessed remotely, which allows a remote attacker to
  interact with the privileged OpenVPN interactive service.
summary: >-
  The interactive service in OpenVPN 2.6.9 and earlier allows the OpenVPN
  service pipe to be accessed remotely, which allows a remote attacker to
  interact with the privileged OpenVPN interactive service.
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N'
cwe:
  - CWE-923
vendor: openvpn
product: openvpn
affected:
  - openvpn < 2.5.10
  - 'openvpn >= 2.6.0, < 2.6.10'
patched:
  - openvpn 2.6.10
published: '2024-07-08'
updated: '2026-11-03'
sourceUpdated: '2026-11-03T22:17:15.597'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2024-24974'
references:
  - url: 'https://community.openvpn.net/openvpn/wiki/CVE-2024-24974'
    label: security@openvpn.net
  - url: >-
      https://openvpn.net/security-advisory/ovpnx-vulnerability-cve-2024-27903-cve-2024-27459-cve-2024-24974/
    label: security@openvpn.net
  - url: >-
      https://www.mail-archive.com/openvpn-users@lists.sourceforge.net/msg07534.html
    label: security@openvpn.net
  - url: 'https://community.openvpn.net/openvpn/wiki/CVE-2024-24974'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: >-
      https://openvpn.net/security-advisory/ovpnx-vulnerability-cve-2024-27903-cve-2024-27459-cve-2024-24974/
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: >-
      https://www.mail-archive.com/openvpn-users@lists.sourceforge.net/msg07534.html
    label: af854a3a-2127-422b-91ae-364da2661108
tags:
  - nvd
  - cve.org
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2024-07-30T18:38:55.346204Z'
epss: 0.09759
epssPercentile: 0.95559
ingestedAt: '2026-11-05T06:38:03.571Z'
---

## Overview

The interactive service in OpenVPN 2.6.9 and earlier allows the OpenVPN service pipe to be accessed remotely, which allows a remote attacker to interact with the privileged OpenVPN interactive service.

## Affected

- `openvpn < 2.5.10`
- `openvpn >= 2.6.0, < 2.6.10`

## Remediation

Upgrade past the affected range:

- `openvpn 2.6.10`
