---
id: CVE-2024-32475
title: 'Envoy RELEASE_ASSERT using auto_sni with :authority header > 255 bytes'
summary: >-
  Envoy is a cloud-native, open source edge and service proxy. When an upstream
  TLS cluster is used with `auto_sni` enabled, a request containing a
  `host`/`:authority` header longer than 255 characters triggers an abnormal
  termination of E…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H'
cvssSource: cna
cwe:
  - CWE-253
  - CWE-617
vendor: envoyproxy
product: envoy
affected:
  - 'envoy >= 1.30.0, < 1.30.1'
  - 'envoy >= 1.29.0, < 1.29.4'
  - 'envoy >= 1.28.0, < 1.28.3'
  - 'envoy >= 1.13.0, < 1.27.5'
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2024-04-23T19:38:07.050413Z'
published: '2024-04-18'
updated: '2026-11-05'
sourceUpdated: '2026-11-05T15:54:20.286Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2024-32475'
references:
  - url: >-
      https://github.com/envoyproxy/envoy/security/advisories/GHSA-3mh5-6q8v-25wj
    label: >-
      https://github.com/envoyproxy/envoy/security/advisories/GHSA-3mh5-6q8v-25wj
  - url: >-
      https://github.com/envoyproxy/envoy/commit/b47fc6648d7c2dfe0093a601d44cb704b7bad382
    label: >-
      https://github.com/envoyproxy/envoy/commit/b47fc6648d7c2dfe0093a601d44cb704b7bad382
tags:
  - cve.org
epss: 0.00679
epssPercentile: 0.52475
ingestedAt: '2026-11-05T21:36:00.931Z'
---

## Overview

Envoy is a cloud-native, open source edge and service proxy. When an upstream TLS cluster is used with `auto_sni` enabled, a request containing a `host`/`:authority` header longer than 255 characters triggers an abnormal termination of Envoy process. Envoy does not gracefully handle an error when setting SNI for outbound TLS connection. The error can occur when Envoy attempts to use the `host`/`:authority` header value longer than 255 characters as SNI for outbound TLS connection. SNI length is limited to 255 characters per the standard. Envoy always expects this operation to succeed and abnormally aborts the process when it fails. This vulnerability is fixed in 1.30.1, 1.29.4, 1.28.3, and 1.27.5.

## Affected

- `envoy >= 1.30.0, < 1.30.1`
- `envoy >= 1.29.0, < 1.29.4`
- `envoy >= 1.28.0, < 1.28.3`
- `envoy >= 1.13.0, < 1.27.5`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
