---
id: CVE-2024-35983
title: |-
  In the Linux kernel, the following vulnerability has been resolved:

  bounds: Use the right number of bits for power-of-two CONFIG_NR_CPUS

  bits_per() rounds up to the next power of two when passed a power of
  two
summary: |-
  In the Linux kernel, the following vulnerability has been resolved:

  bounds: Use the right number of bits for power-of-two CONFIG_NR_CPUS

  bits_per() rounds up to the next power of two when passed a power of
  two.  This causes crashes on …
severity: medium
cvss: 5.5
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H'
vendor: linux
product: linux_kernel
affected:
  - 'linux_kernel >= 5.4.274, < 5.4.275'
  - 'linux_kernel >= 5.10.215, < 5.10.216'
  - 'linux_kernel >= 5.15.154, < 5.15.158'
  - 'linux_kernel >= 6.1.84, < 6.1.90'
  - 'linux_kernel >= 6.6.24, < 6.6.30'
  - 'linux_kernel >= 6.7.12, < 6.8'
  - 'linux_kernel >= 6.8.3, < 6.8.9'
patched:
  - linux_kernel 6.8.9
published: '2024-05-20'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T01:18:16.113'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2024-35983'
references:
  - url: 'https://git.kernel.org/stable/c/15aa09d6d84629eb5296de30ac0aa19a33512f16'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/5af385f5f4cddf908f663974847a4083b2ff2c79'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/66297b2ceda841f809637731d287bda3a93b49d8'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/93ba36238db6a74a82feb3dc476e25ea424ad630'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/9b7c5004d7c5ae062134052a85290869a015814c'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/d34a516f2635090d36a306f84573e8de3d7374ce'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/ebfe41889b762f1933c6762f6624b9724a25bee0'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/15aa09d6d84629eb5296de30ac0aa19a33512f16'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://git.kernel.org/stable/c/5af385f5f4cddf908f663974847a4083b2ff2c79'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://git.kernel.org/stable/c/66297b2ceda841f809637731d287bda3a93b49d8'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://git.kernel.org/stable/c/93ba36238db6a74a82feb3dc476e25ea424ad630'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://git.kernel.org/stable/c/9b7c5004d7c5ae062134052a85290869a015814c'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://git.kernel.org/stable/c/d34a516f2635090d36a306f84573e8de3d7374ce'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://git.kernel.org/stable/c/ebfe41889b762f1933c6762f6624b9724a25bee0'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://lists.debian.org/debian-lts-announce/2024/06/msg00017.html'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://cert-portal.siemens.com/productcert/html/ssa-265688.html'
    label: 0b142b55-0307-4c5a-b3c9-f314f3fb7c5e
  - url: 'https://cert-portal.siemens.com/productcert/html/ssa-613116.html'
    label: 0b142b55-0307-4c5a-b3c9-f314f3fb7c5e
tags:
  - nvd
  - cve.org
epss: 0.00236
epssPercentile: 0.1454
ingestedAt: '2026-10-15T03:30:12.695Z'
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2024-05-20T13:33:05.860363Z'
---

## Overview

In the Linux kernel, the following vulnerability has been resolved:

bounds: Use the right number of bits for power-of-two CONFIG_NR_CPUS

bits_per() rounds up to the next power of two when passed a power of
two.  This causes crashes on some machines and configurations.

## Affected

- `linux_kernel >= 5.4.274, < 5.4.275`
- `linux_kernel >= 5.10.215, < 5.10.216`
- `linux_kernel >= 5.15.154, < 5.15.158`
- `linux_kernel >= 6.1.84, < 6.1.90`
- `linux_kernel >= 6.6.24, < 6.6.30`
- `linux_kernel >= 6.7.12, < 6.8`
- `linux_kernel >= 6.8.3, < 6.8.9`

## Remediation

Upgrade past the affected range:

- `linux_kernel 6.8.9`
