---
id: CVE-2024-36974
title: |-
  In the Linux kernel, the following vulnerability has been resolved:

  net/sched: taprio: always validate TCA_TAPRIO_ATTR_PRIOMAP

  If one TCA_TAPRIO_ATTR_PRIOMAP attribute has been provided,
  taprio_parse_mqprio_opt() must validate it, or u…
summary: |-
  In the Linux kernel, the following vulnerability has been resolved:

  net/sched: taprio: always validate TCA_TAPRIO_ATTR_PRIOMAP

  If one TCA_TAPRIO_ATTR_PRIOMAP attribute has been provided,
  taprio_parse_mqprio_opt() must validate it, or u…
severity: high
cvss: 7.8
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'
vendor: linux
product: linux_kernel
affected:
  - 'linux_kernel >= 5.2, < 5.4.279'
  - 'linux_kernel >= 5.5, < 5.10.221'
  - 'linux_kernel >= 5.11, < 5.15.162'
  - 'linux_kernel >= 5.16, < 6.1.95'
  - 'linux_kernel >= 6.2, < 6.6.35'
  - 'linux_kernel >= 6.7, < 6.9.6'
  - linux_kernel = 6.10
patched:
  - linux_kernel 6.9.6
published: '2024-06-18'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T01:18:26.790'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2024-36974'
references:
  - url: 'https://git.kernel.org/stable/c/0bf6cc96612bd396048f57d63f1ad454a846e39c'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/6db4af09987cc5d5f0136bd46148b0e0460dae5b'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/724050ae4b76e4fae05a923cb54101d792cf4404'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/c37a27a35eadb59286c9092c49c241270c802ae2'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/c6041e7124464ce7e896ee3f912897ce88a0c4ec'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/d3dde4c217f0c31ab0621912e682b57e677dd923'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/f921a58ae20852d188f70842431ce6519c4fdc36'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/0bf6cc96612bd396048f57d63f1ad454a846e39c'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://git.kernel.org/stable/c/6db4af09987cc5d5f0136bd46148b0e0460dae5b'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://git.kernel.org/stable/c/724050ae4b76e4fae05a923cb54101d792cf4404'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://git.kernel.org/stable/c/c37a27a35eadb59286c9092c49c241270c802ae2'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://git.kernel.org/stable/c/c6041e7124464ce7e896ee3f912897ce88a0c4ec'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://git.kernel.org/stable/c/d3dde4c217f0c31ab0621912e682b57e677dd923'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://git.kernel.org/stable/c/f921a58ae20852d188f70842431ce6519c4fdc36'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://cert-portal.siemens.com/productcert/html/ssa-265688.html'
    label: 0b142b55-0307-4c5a-b3c9-f314f3fb7c5e
  - url: 'https://cert-portal.siemens.com/productcert/html/ssa-355557.html'
    label: 0b142b55-0307-4c5a-b3c9-f314f3fb7c5e
  - url: 'https://cert-portal.siemens.com/productcert/html/ssa-613116.html'
    label: 0b142b55-0307-4c5a-b3c9-f314f3fb7c5e
tags:
  - nvd
  - cve.org
epss: 0.00284
epssPercentile: 0.20776
ingestedAt: '2026-10-15T03:30:12.704Z'
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2024-09-10T17:15:26.013777Z'
---

## Overview

In the Linux kernel, the following vulnerability has been resolved:

net/sched: taprio: always validate TCA_TAPRIO_ATTR_PRIOMAP

If one TCA_TAPRIO_ATTR_PRIOMAP attribute has been provided,
taprio_parse_mqprio_opt() must validate it, or userspace
can inject arbitrary data to the kernel, the second time
taprio_change() is called.

First call (with valid attributes) sets dev->num_tc
to a non zero value.

Second call (with arbitrary mqprio attributes)
returns early from taprio_parse_mqprio_opt()
and bad things can happen.

## Affected

- `linux_kernel >= 5.2, < 5.4.279`
- `linux_kernel >= 5.5, < 5.10.221`
- `linux_kernel >= 5.11, < 5.15.162`
- `linux_kernel >= 5.16, < 6.1.95`
- `linux_kernel >= 6.2, < 6.6.35`
- `linux_kernel >= 6.7, < 6.9.6`
- `linux_kernel = 6.10`

## Remediation

Upgrade past the affected range:

- `linux_kernel 6.9.6`
