---
id: CVE-2024-37081
title: "The vCenter Server contains multiple local privilege escalation vulnerabilities due to misconfiguration of sudo.\_An authenticated local user with non-administrative privileges may exploit these issues to elevate privileges to root on vCe…"
summary: "The vCenter Server contains multiple local privilege escalation vulnerabilities due to misconfiguration of sudo.\_An authenticated local user with non-administrative privileges may exploit these issues to elevate privileges to root on vCe…"
severity: high
cvss: 7.8
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-556
vendor: vmware
product: vcenter_server
affected:
  - vcenter_server = 8.0
  - vcenter_server = 7.0
  - 'cloud_foundation >= 4.0, < 5.2'
patched:
  - cloud_foundation 5.2
published: '2024-06-18'
updated: '2026-11-03'
sourceUpdated: '2026-11-03T22:17:20.783'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2024-37081'
references:
  - url: >-
      https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24453
    label: security@vmware.com
  - url: >-
      https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/24453
    label: af854a3a-2127-422b-91ae-364da2661108
tags:
  - nvd
  - cve.org
  - exploit-available
exploitAvailable: true
ssvc:
  exploitation: poc
  automatable: 'no'
  technicalImpact: total
  timestamp: '2024-07-11T03:55:32.852546Z'
epss: 0.04989
epssPercentile: 0.92266
exploits:
  github: 3
  githubRepos:
    - 'https://github.com/mbadanoiu/CVE-2024-37081'
    - 'https://github.com/Mr-r00t11/CVE-2024-37081'
    - 'https://github.com/CERTologists/Modified-CVE-2024-37081-POC'
  metasploit:
    - exploit/linux/local/vcenter_sudo_lpe
  checkedAt: '2026-11-07T17:44:40.664Z'
ingestedAt: '2026-11-05T06:38:03.569Z'
---

## Overview

The vCenter Server contains multiple local privilege escalation vulnerabilities due to misconfiguration of sudo. An authenticated local user with non-administrative privileges may exploit these issues to elevate privileges to root on vCenter Server Appliance.

## Affected

- `vcenter_server = 8.0`
- `vcenter_server = 7.0`
- `cloud_foundation >= 4.0, < 5.2`

## Remediation

Upgrade past the affected range:

- `cloud_foundation 5.2`
