CVE-2024-41937Medium· 6.1▾ SunlitApache Airflow Cross-site Scripting Vulnerability
▾ Sunlit zone — Low / medium · no exploitation signal
impact 33.6 · likelihood 0.3 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Exploit-prediction probability, daily snapshots since Sep 12.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via OSV
Last analysed / modified upstream
1.7%
Apache Airflow, versions before 2.10.0, have a vulnerability that allows the developer of a malicious provider to execute a cross-site scripting attack when clicking on a provider documentation link. This would require the provider to be installed on the web server and the user to click the provider link. Users should upgrade to 2.10.0 or later, which fixes this vulnerability.
apache-airflow < 2.10.0Upgrade to a patched release:
apache-airflow 2.10.0Connected by shared product, vendor, weakness, or advisory.
CVE-2022-40189Critical· 9.8OS Command Injection in Apache Airflow
CVE-2022-38649Critical· 9.8OS Command Injection in Apache Airflow
CVE-2023-22884Critical· 9.8Command Injection in Apache Airflow and Apache Airflow MySQL Provider
CVE-2026-34538Medium· 6.5Apache Airflow has an authorization bypass in DagRun wait endpoint
CVE-2026-22922Medium· 6.5Apache Airflow Has an Authorization Bypass That Allows Unauthorized Task Log Access
CVE-2024-39863Medium· 5.4Apache Airflow Potential Cross-site Scripting Vulnerability