---
id: CVE-2024-42097
title: |-
  In the Linux kernel, the following vulnerability has been resolved:

  ALSA: emux: improve patch ioctl data validation

  In load_data(), make the validation of and skipping over the main info
  block match that in load_guspatch().

  In load_gu…
summary: |-
  In the Linux kernel, the following vulnerability has been resolved:

  ALSA: emux: improve patch ioctl data validation

  In load_data(), make the validation of and skipping over the main info
  block match that in load_guspatch().

  In load_gu…
severity: high
cvss: 7.8
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'
vendor: linux
product: linux_kernel
affected:
  - linux_kernel < 4.19.317
  - 'linux_kernel >= 4.20, < 5.4.279'
  - 'linux_kernel >= 5.5, < 5.10.221'
  - 'linux_kernel >= 5.11, < 5.15.162'
  - 'linux_kernel >= 5.16, < 6.1.97'
  - 'linux_kernel >= 6.2, < 6.6.37'
  - 'linux_kernel >= 6.7, < 6.9.8'
patched:
  - linux_kernel 6.9.8
published: '2024-07-29'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T01:18:43.533'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2024-42097'
references:
  - url: 'https://git.kernel.org/stable/c/40d7def67841343c10f8642a41031fecbb248bab'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/79d9a000f0220cdaba1682d2a23c0d0c61d620a3'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/7a18293fd8d8519c2f7a03753bc1583b18e3db69'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/87039b83fb7bfd7d0e0499aaa8e6c049906b4d14'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/89b32ccb12ae67e630c6453d778ec30a592a212f'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/d0ff2443fcbb472206d45a5d2a90cc694065804e'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/d23982ea9aa438f35a8c8a6305943e98a8db90f6'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/d8f5ce3cb9adf0c72e2ad6089aba02d7a32469c2'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/40d7def67841343c10f8642a41031fecbb248bab'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://git.kernel.org/stable/c/79d9a000f0220cdaba1682d2a23c0d0c61d620a3'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://git.kernel.org/stable/c/7a18293fd8d8519c2f7a03753bc1583b18e3db69'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://git.kernel.org/stable/c/87039b83fb7bfd7d0e0499aaa8e6c049906b4d14'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://git.kernel.org/stable/c/89b32ccb12ae67e630c6453d778ec30a592a212f'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://git.kernel.org/stable/c/d0ff2443fcbb472206d45a5d2a90cc694065804e'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://git.kernel.org/stable/c/d23982ea9aa438f35a8c8a6305943e98a8db90f6'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://git.kernel.org/stable/c/d8f5ce3cb9adf0c72e2ad6089aba02d7a32469c2'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://cert-portal.siemens.com/productcert/html/ssa-265688.html'
    label: 0b142b55-0307-4c5a-b3c9-f314f3fb7c5e
tags:
  - nvd
  - cve.org
epss: 0.00231
epssPercentile: 0.13929
ingestedAt: '2026-10-15T03:30:12.729Z'
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2024-09-10T16:18:18.485738Z'
---

## Overview

In the Linux kernel, the following vulnerability has been resolved:

ALSA: emux: improve patch ioctl data validation

In load_data(), make the validation of and skipping over the main info
block match that in load_guspatch().

In load_guspatch(), add checking that the specified patch length matches
the actually supplied data, like load_data() already did.

## Affected

- `linux_kernel < 4.19.317`
- `linux_kernel >= 4.20, < 5.4.279`
- `linux_kernel >= 5.5, < 5.10.221`
- `linux_kernel >= 5.11, < 5.15.162`
- `linux_kernel >= 5.16, < 6.1.97`
- `linux_kernel >= 6.2, < 6.6.37`
- `linux_kernel >= 6.7, < 6.9.8`

## Remediation

Upgrade past the affected range:

- `linux_kernel 6.9.8`
