---
id: CVE-2024-42304
title: |-
  In the Linux kernel, the following vulnerability has been resolved:

  ext4: make sure the first directory block is not a hole

  The syzbot constructs a directory that has no dirblock but is non-inline,
  i.e
summary: |-
  In the Linux kernel, the following vulnerability has been resolved:

  ext4: make sure the first directory block is not a hole

  The syzbot constructs a directory that has no dirblock but is non-inline,
  i.e. the first directory block is a h…
severity: high
cvss: 7.8
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'
vendor: linux
product: linux_kernel
affected:
  - 'linux_kernel >= 4.9.187, < 4.10'
  - 'linux_kernel >= 4.14.135, < 4.15'
  - 'linux_kernel >= 4.19.62, < 4.19.320'
  - 'linux_kernel >= 5.1.21, < 5.2'
  - 'linux_kernel >= 5.2.4, < 5.4.282'
  - 'linux_kernel >= 5.5, < 5.10.224'
  - 'linux_kernel >= 5.11, < 5.15.165'
  - 'linux_kernel >= 5.16, < 6.1.103'
  - 'linux_kernel >= 6.2, < 6.6.44'
  - 'linux_kernel >= 6.7, < 6.10.3'
patched:
  - linux_kernel 6.10.3
published: '2024-08-17'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T01:18:46.087'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2024-42304'
references:
  - url: 'https://git.kernel.org/stable/c/299bc6ffa57e04e74c6cce866d6c0741fb4897a1'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/9771e3d8365ae1dd5e8846a204cb9af14e3e656a'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/b609753cbbd38f8c0affd4956c0af178348523ac'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/c3893d9de8ee153baac56d127d844103488133b5'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/d81d7e347d1f1f48a5634607d39eb90c161c8afe'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/de2a011a13a46468a6e8259db58b1b62071fe136'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/e02f9941e8c011aa3eafa799def6a134ce06bcfa'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/f9ca51596bbfd0f9c386dd1c613c394c78d9e5e6'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://lists.debian.org/debian-lts-announce/2024/10/msg00003.html'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://cert-portal.siemens.com/productcert/html/ssa-265688.html'
    label: 0b142b55-0307-4c5a-b3c9-f314f3fb7c5e
tags:
  - nvd
  - cve.org
epss: 0.00234
epssPercentile: 0.14398
ingestedAt: '2026-10-15T03:30:12.733Z'
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2024-09-10T16:10:22.365835Z'
---

## Overview

In the Linux kernel, the following vulnerability has been resolved:

ext4: make sure the first directory block is not a hole

The syzbot constructs a directory that has no dirblock but is non-inline,
i.e. the first directory block is a hole. And no errors are reported when
creating files in this directory in the following flow.

    ext4_mknod
     ...
      ext4_add_entry
        // Read block 0
        ext4_read_dirblock(dir, block, DIRENT)
          bh = ext4_bread(NULL, inode, block, 0)
          if (!bh && (type == INDEX || type == DIRENT_HTREE))
          // The first directory block is a hole
          // But type == DIRENT, so no error is reported.

After that, we get a directory block without '.' and '..' but with a valid
dentry. This may cause some code that relies on dot or dotdot (such as
make_indexed_dir()) to crash.

Therefore when ext4_read_dirblock() finds that the first directory block
is a hole report that the filesystem is corrupted and return an error to
avoid loading corrupted data from disk causing something bad.

## Affected

- `linux_kernel >= 4.9.187, < 4.10`
- `linux_kernel >= 4.14.135, < 4.15`
- `linux_kernel >= 4.19.62, < 4.19.320`
- `linux_kernel >= 5.1.21, < 5.2`
- `linux_kernel >= 5.2.4, < 5.4.282`
- `linux_kernel >= 5.5, < 5.10.224`
- `linux_kernel >= 5.11, < 5.15.165`
- `linux_kernel >= 5.16, < 6.1.103`
- `linux_kernel >= 6.2, < 6.6.44`
- `linux_kernel >= 6.7, < 6.10.3`

## Remediation

Upgrade past the affected range:

- `linux_kernel 6.10.3`
