---
id: CVE-2024-44960
title: |-
  In the Linux kernel, the following vulnerability has been resolved:

  usb: gadget: core: Check for unset descriptor

  Make sure the descriptor has been set before looking at maxpacket.
  This fixes a null pointer panic in this case.

  This ma…
summary: |-
  In the Linux kernel, the following vulnerability has been resolved:

  usb: gadget: core: Check for unset descriptor

  Make sure the descriptor has been set before looking at maxpacket.
  This fixes a null pointer panic in this case.

  This ma…
severity: medium
cvss: 5.5
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H'
cwe:
  - CWE-476
vendor: linux
product: linux_kernel
affected:
  - linux_kernel < 3.16.80
  - 'linux_kernel >= 3.17, < 4.4.199'
  - 'linux_kernel >= 4.5, < 4.9.199'
  - 'linux_kernel >= 4.10, < 4.14.152'
  - 'linux_kernel >= 4.15, < 4.19.320'
  - 'linux_kernel >= 4.20, < 5.3.9'
  - 'linux_kernel >= 5.4, < 5.4.282'
  - 'linux_kernel >= 5.5, < 5.10.224'
  - 'linux_kernel >= 5.11, < 5.15.165'
  - 'linux_kernel >= 5.16, < 6.1.105'
  - 'linux_kernel >= 6.2, < 6.6.46'
  - 'linux_kernel >= 6.7, < 6.10.5'
  - linux_kernel = 6.11
patched:
  - linux_kernel 6.10.5
published: '2024-09-04'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T01:18:50.283'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2024-44960'
references:
  - url: 'https://git.kernel.org/stable/c/1a9df57d57452b104c46c918569143cf21d7ebf1'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/50c5248b0ea8aae0529fdf28dac42a41312d3b62'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/716cba46f73a92645cf13eded8d257ed48afc2a4'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/7cc9ebcfe58be22f18056ad8bc6272d120bdcb3e'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/973a57891608a98e894db2887f278777f564de18'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/a0362cd6e503278add954123957fd47990e8d9bf'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/ba15815dd24cc5ec0d23e2170dc58c7db1e03b4a'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/df8e734ae5e605348aa0ca2498aedb73e815f244'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://lists.debian.org/debian-lts-announce/2024/10/msg00003.html'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html'
    label: af854a3a-2127-422b-91ae-364da2661108
  - url: 'https://cert-portal.siemens.com/productcert/html/ssa-265688.html'
    label: 0b142b55-0307-4c5a-b3c9-f314f3fb7c5e
  - url: 'https://cert-portal.siemens.com/productcert/html/ssa-355557.html'
    label: 0b142b55-0307-4c5a-b3c9-f314f3fb7c5e
  - url: 'https://cert-portal.siemens.com/productcert/html/ssa-613116.html'
    label: 0b142b55-0307-4c5a-b3c9-f314f3fb7c5e
tags:
  - nvd
  - cve.org
epss: 0.00239
epssPercentile: 0.14937
ingestedAt: '2026-10-15T03:30:12.739Z'
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2024-09-10T17:39:50.689815Z'
---

## Overview

In the Linux kernel, the following vulnerability has been resolved:

usb: gadget: core: Check for unset descriptor

Make sure the descriptor has been set before looking at maxpacket.
This fixes a null pointer panic in this case.

This may happen if the gadget doesn't properly set up the endpoint
for the current speed, or the gadget descriptors are malformed and
the descriptor for the speed/endpoint are not found.

No current gadget driver is known to have this problem, but this
may cause a hard-to-find bug during development of new gadgets.

## Affected

- `linux_kernel < 3.16.80`
- `linux_kernel >= 3.17, < 4.4.199`
- `linux_kernel >= 4.5, < 4.9.199`
- `linux_kernel >= 4.10, < 4.14.152`
- `linux_kernel >= 4.15, < 4.19.320`
- `linux_kernel >= 4.20, < 5.3.9`
- `linux_kernel >= 5.4, < 5.4.282`
- `linux_kernel >= 5.5, < 5.10.224`
- `linux_kernel >= 5.11, < 5.15.165`
- `linux_kernel >= 5.16, < 6.1.105`
- `linux_kernel >= 6.2, < 6.6.46`
- `linux_kernel >= 6.7, < 6.10.5`
- `linux_kernel = 6.11`

## Remediation

Upgrade past the affected range:

- `linux_kernel 6.10.5`
