---
id: CVE-2024-49541
title: >-
  Illustrator versions 29.0.0, 28.7.2 and earlier are affected by an
  out-of-bounds read vulnerability that could lead to disclosure of sensitive
  memory
summary: >-
  Illustrator versions 29.0.0, 28.7.2 and earlier are affected by an
  out-of-bounds read vulnerability that could lead to disclosure of sensitive
  memory. An attacker could leverage this vulnerability to bypass mitigations
  such as ASLR. Expl…
severity: medium
cvss: 5.5
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N'
cwe:
  - CWE-125
vendor: adobe
product: illustrator
affected:
  - illustrator < 28.7.3
  - illustrator = 29.0
patched:
  - illustrator 28.7.3
published: '2024-12-10'
updated: '2026-11-03'
sourceUpdated: '2026-11-03T22:17:26.187'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2024-49541'
references:
  - url: 'https://helpx.adobe.com/security/products/illustrator/apsb24-94.html'
    label: psirt@adobe.com
tags:
  - nvd
  - cve.org
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2024-12-17T04:55:27.192011Z'
epss: 0.00334
epssPercentile: 0.2694
ingestedAt: '2026-11-05T06:38:03.584Z'
---

## Overview

Illustrator versions 29.0.0, 28.7.2 and earlier are affected by an out-of-bounds read vulnerability that could lead to disclosure of sensitive memory. An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

## Affected

- `illustrator < 28.7.3`
- `illustrator = 29.0`

## Remediation

Upgrade past the affected range:

- `illustrator 28.7.3`
