CVE-2024-5023Critical· 9.6▾ MidnightConsoleMe has an Arbitrary File Read Vulnerability via Limited Git command
▾ Midnight zone — Critical, or high with PoC / in-the-wild
impact 52.8 · likelihood 0.2 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Exploit-prediction probability, daily snapshots since Oct 27.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via OSV
Last analysed / modified upstream
0.9%
Authenticated users can achieve limited RCE in ConsoleMe, restricted to flag inputs on a single CLI command. Due to this constraint, it is not currently known whether full RCE is possible but it is unlikely. However, a specific flag allows authenticated users to read any server files accessible by the ConsoleMe process. Given ConsoleMe's role as an AWS identity broker, accessing files containing secrets on the server could potentially be exploited for privilege escalation.
Deployments of ConsoleMe that allow templated resources are impacted and urged to patch immediately. Deployments that do not permit templated resources are not affected.
To determine if your ConsoleMe deployment uses templated resources, check the configuration value for cache_resource_templates.repositories. If this value does not exist or is an empty array, your deployment is not impacted.
The self-service flow for templated resources in ConsoleMe accepts a user-supplied JSON post body, which includes the filename for the templated resource. However, this user-supplied filename is not properly sanitized and is passed directly as a string to a CLI command. This allows users to input flags instead of filenames. By passing a specific flag with a filename value, users can induce an error that reveals the contents of the specified file, allowing them to read any files readable by the system user executing the ConsoleMe server process.
This issue has been patched in version v1.4.0 via https://github.com/Netflix/consoleme/pull/9380.
If you are unable to upgrade to the latest version, users can selectively apply the code changes in the above PR. Alternatively, removing the configuration item cache_resource_templates.repositories or adding it as an empty array should mitigate the issue, but will result in broken functionality (templated resources will no longer be supported for self-service).
consoleme < 1.4.0Upgrade to a patched release:
consoleme 1.4.0Connected by shared product, vendor, weakness, or advisory.
CVE-2024-10190Critical· 9.8Horovod Vulnerable to Command Injection
CVE-2022-46421Critical· 9.8Apache Airflow Hive Provider vulnerable to Command Injection
CVE-2023-22884Critical· 9.8Command Injection in Apache Airflow and Apache Airflow MySQL Provider
CVE-2025-14648Medium· 4.7A security vulnerability has been detected in DedeBIZ up to 6.5.9
CVE-2025-59831High· 8.8git-commiters is a Node.js function module providing committers stats for their git repository
CVE-2025-12313Medium· 6.3A vulnerability has been found in D-Link DI-7001 MINI 19.09.19A1/24.04.18B1