---
id: CVE-2024-57793
title: |-
  In the Linux kernel, the following vulnerability has been resolved:

  virt: tdx-guest: Just leak decrypted memory on unrecoverable errors

  In CoCo VMs it is possible for the untrusted host to cause
  set_memory_decrypted() to fail such that…
summary: |-
  In the Linux kernel, the following vulnerability has been resolved:

  virt: tdx-guest: Just leak decrypted memory on unrecoverable errors

  In CoCo VMs it is possible for the untrusted host to cause
  set_memory_decrypted() to fail such that…
severity: critical
cvss: 9.3
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H'
cwe:
  - CWE-401
vendor: linux
product: linux_kernel
affected:
  - 'linux_kernel >= 6.7, < 6.12.8'
  - linux_kernel = 6.13
patched:
  - linux_kernel 6.12.8
published: '2025-01-11'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T22:18:03.030'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2024-57793'
references:
  - url: 'https://git.kernel.org/stable/c/1429ae7b7d4759a1e362456b8911c701bae655b4'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
  - url: 'https://git.kernel.org/stable/c/27834971f616c5e154423c578fa95e0444444ce1'
    label: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
tags:
  - nvd
  - cve.org
epss: 0.00203
epssPercentile: 0.10141
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-15T21:41:27.698751Z'
ingestedAt: '2026-10-15T22:48:25.461Z'
---

## Overview

In the Linux kernel, the following vulnerability has been resolved:

virt: tdx-guest: Just leak decrypted memory on unrecoverable errors

In CoCo VMs it is possible for the untrusted host to cause
set_memory_decrypted() to fail such that an error is returned
and the resulting memory is shared. Callers need to take care
to handle these errors to avoid returning decrypted (shared)
memory to the page allocator, which could lead to functional
or security issues.

Leak the decrypted memory when set_memory_decrypted() fails,
and don't need to print an error since set_memory_decrypted()
will call WARN_ONCE().

## Affected

- `linux_kernel >= 6.7, < 6.12.8`
- `linux_kernel = 6.13`

## Remediation

Upgrade past the affected range:

- `linux_kernel 6.12.8`
