---
id: CVE-2024-58398
title: Coder 2.3.1 before 2.16.1 Open Redirect via Login Page redirect Parameter
summary: >-
  Coder 2.3.1 before 2.14.4, 2.15.x before 2.15.3, and 2.16.0 before 2.16.1
  contains an open redirect vulnerability in the login page because the redirect
  query parameter is improperly sanitized. Attackers can craft a Coder login URL
  that,…
severity: medium
cvss: 4.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-601
vendor: coder
product: coder
affected:
  - coder >= 2.16.0 < 2.16.1
  - coder >= 2.15.0 < 2.15.3
  - coder >= 2.3.1 < 2.14.4
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-21T21:34:49.806627Z'
published: '2026-10-17'
updated: '2026-10-21'
sourceUpdated: '2026-10-21T21:34:59.156Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2024-58398'
references:
  - url: 'https://github.com/coder/coder/security/advisories/GHSA-wcx9-ccpj-hx3c'
    label: GitHub Security Advisory (GHSA-wcx9-ccpj-hx3c)
  - url: >-
      https://github.com/coder/coder/commit/69c1d981e3131e50d52b01f6a360abadaad699e6
    label: Patch Commit
  - url: >-
      https://www.vulncheck.com/advisories/coder-2.3.1-before-2.16.1-open-redirect-via-login-page-redirect-parameter
    label: >-
      VulnCheck Advisory: Coder 2.3.1 before 2.16.1 Open Redirect via Login Page
      redirect Parameter
  - url: 'https://github.com/coder/coder'
tags:
  - cve.org
  - osv
  - go
epss: 0.00268
epssPercentile: 0.18875
aliases:
  - GHSA-wcx9-ccpj-hx3c
  - GO-2024-3228
ecosystem: go
patched:
  - github.com/coder/coder/v2 2.16.1
  - github.com/coder/coder/v2 2.15.3
  - github.com/coder/coder/v2 2.14.4
ingestedAt: '2026-10-17T19:08:56.995Z'
---

## Overview

Coder 2.3.1 before 2.14.4, 2.15.x before 2.15.3, and 2.16.0 before 2.16.1 contains an open redirect vulnerability in the login page because the redirect query parameter is improperly sanitized. Attackers can craft a Coder login URL that, when clicked by a logged-in user, redirects the victim to an attacker-controlled website for phishing.

## Affected

- `coder >= 2.16.0 < 2.16.1`
- `coder >= 2.15.0 < 2.15.3`
- `coder >= 2.3.1 < 2.14.4`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2024-58398)

Affected packages:

- `github.com/coder/coder/v2 >= 2.16.0, < 2.16.1`
- `github.com/coder/coder/v2 >= 2.15.0, < 2.15.3`
- `github.com/coder/coder/v2 >= 2.3.1, < 2.14.4`

Patched in:

- `github.com/coder/coder/v2 2.16.1`
- `github.com/coder/coder/v2 2.15.3`
- `github.com/coder/coder/v2 2.14.4`

Source: https://osv.dev/vulnerability/GHSA-wcx9-ccpj-hx3c
