---
id: CVE-2024-6091
aliases:
  - GHSA-g84q-54hf-36rg
  - PYSEC-2026-257
title: AutoGPT bypass of the shell commands denylist settings
summary: AutoGPT bypass of the shell commands denylist settings
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
vendor: agpt
product: agpt
ecosystem: pip
affected:
  - agpt <= 0.5.1
published: '2024-09-11'
updated: '2026-10-26'
sourceUpdated: '2026-10-26T21:15:03.687137353Z'
source: OSV
sourceUrl: 'https://osv.dev/vulnerability/GHSA-g84q-54hf-36rg'
references:
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2024-6091'
  - url: >-
      https://github.com/significant-gravitas/autogpt/commit/ef691359b774a1f9f80cf4f5ace9821967b718ed
  - url: 'https://github.com/Significant-Gravitas/AutoGPT'
  - url: >-
      https://github.com/pypa/advisory-database/tree/main/vulns/agpt/PYSEC-2026-257.yaml
  - url: 'https://huntr.com/bounties/8a742c13-bb5e-4bc9-8b86-049d8a386050'
  - url: 'https://pypi.org/project/agpt'
  - url: 'https://github.com/advisories/GHSA-g84q-54hf-36rg'
tags:
  - osv
  - pip
  - ghsa
epss: 0.00819
epssPercentile: 0.56982
cwe:
  - CWE-78
ingestedAt: '2026-10-27T16:11:58.782Z'
---

## Overview

A vulnerability in significant-gravitas/autogpt version 0.5.1 allows an attacker to bypass the shell commands denylist settings. The issue arises when the denylist is configured to block specific commands, such as `whoami` and `/bin/whoami`. An attacker can circumvent this restriction by executing commands with a modified path, such as `/bin/./whoami`, which is not recognized by the denylist.

## Affected packages

- `agpt <= 0.5.1`

## Remediation

Refer to the advisory for the patched release.
