---
id: CVE-2024-9375
title: >-
  The WordPress Captcha Plugin by Captcha Bank plugin for WordPress is
  vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg
  without appropriate escaping on the URL in all versions up to, and including,
  4.0.36
summary: >-
  The WordPress Captcha Plugin by Captcha Bank plugin for WordPress is
  vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg
  without appropriate escaping on the URL in all versions up to, and including,
  4.0.36. This …
severity: medium
cvss: 6.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
vendor: tech-banker
product: captcha_bank
affected:
  - captcha_bank <= 4.0.36
published: '2024-10-04'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T20:31:36.323'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2024-9375'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/captcha-bank/trunk/captcha-bank.php#L1297
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/ba796adc-db76-4b9d-a6f9-f0f51f070240?source=cve
    label: security@wordfence.com
tags:
  - nvd
epss: 0.00317
epssPercentile: 0.24471
ingestedAt: '2026-10-27T20:56:38.284Z'
---

## Overview

The WordPress Captcha Plugin by Captcha Bank plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 4.0.36. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

## Affected

- `captcha_bank <= 4.0.36`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
