CVE-2024-9675High· 7.8▾ TwilightA vulnerability was found in Buildah. Cache mounts do not properly validate that user-specified paths for the cache are within our cache directory, allowing a `RUN` instruction in a Container file to mount an arbitrary directory from the…
▾ Twilight zone — High severity, or a signal on a lesser flaw
impact 42.9 · likelihood 0.1 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Exploit-prediction probability, daily snapshots since Jul 29.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via NVD
Last analysed / modified upstream
0.4%
A vulnerability was found in Buildah. Cache mounts do not properly validate that user-specified paths for the cache are within our cache directory, allowing a RUN instruction in a Container file to mount an arbitrary directory from the host (read/write) into the container as long as those files can be accessed by the user running Buildah.
buildahopenshift_container_platform = 4.13openshift_container_platform = 4.14openshift_container_platform = 4.15openshift_container_platform = 4.16openshift_container_platform = 4.17enterprise_linux = 8.0enterprise_linux = 9.0enterprise_linux_eus = 8.8enterprise_linux_eus = 9.0enterprise_linux_eus = 9.2enterprise_linux_eus = 9.4enterprise_linux_for_arm_64 = 8.0_aarch64enterprise_linux_for_arm_64 = 9.0_aarch64enterprise_linux_for_arm_64_eus = 8.8_aarch64enterprise_linux_for_arm_64_eus = 9.0_aarch64enterprise_linux_for_arm_64_eus = 9.2_aarch64enterprise_linux_for_arm_64_eus = 9.4_aarch64enterprise_linux_for_ibm_z_systems = 8.0_s390xenterprise_linux_for_ibm_z_systems = 9.0_s390xenterprise_linux_for_ibm_z_systems_eus = 8.8_s390xenterprise_linux_for_ibm_z_systems_eus = 9.0_s390xenterprise_linux_for_ibm_z_systems_eus = 9.2_s390xenterprise_linux_for_ibm_z_systems_eus = 9.4_s390xenterprise_linux_for_power_little_endian = 8.0_ppc64leenterprise_linux_for_power_little_endian = 9.0_ppc64leenterprise_linux_for_power_little_endian_eus = 8.8_ppc64leenterprise_linux_for_power_little_endian_eus = 9.0_ppc64leenterprise_linux_for_power_little_endian_eus = 9.2_ppc64leenterprise_linux_for_power_little_endian_eus = 9.4_ppc64leenterprise_linux_server_aus = 8.6enterprise_linux_server_aus = 9.2enterprise_linux_server_aus = 9.4enterprise_linux_server_for_power_little_endian_update_services_for_sap_solutions = 8.6_ppc64leenterprise_linux_server_for_power_little_endian_update_services_for_sap_solutions = 8.8_ppc64leenterprise_linux_server_for_power_little_endian_update_services_for_sap_solutions = 9.0_ppc64leenterprise_linux_server_for_power_little_endian_update_services_for_sap_solutions = 9.2_ppc64leenterprise_linux_server_for_power_little_endian_update_services_for_sap_solutions = 9.4_ppc64leenterprise_linux_server_tus = 8.6enterprise_linux_server_tus = 8.8enterprise_linux_update_services_for_sap_solutions = 8.6enterprise_linux_update_services_for_sap_solutions = 8.8enterprise_linux_update_services_for_sap_solutions = 9.0enterprise_linux_update_services_for_sap_solutions = 9.2enterprise_linux_update_services_for_sap_solutions = 9.4Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
Affected packages:
github.com/containers/buildah < 1.38.0Patched in:
github.com/containers/buildah 1.38.0Connected by shared product, vendor, weakness, or advisory.
CVE-2024-1753High· 8.6A flaw was found in Buildah (and subsequently Podman Build) which allows containers to mount arbitrary locations on the host filesystem into build containers
CVE-2025-11395Medium· 5.5A flaw was found in Podman
CVE-2022-37906Medium· 6.5An authenticated path traversal vulnerability exists in the ArubaOS command line interface
CVE-2024-13986High· 8.8Nagios XI < 2024R1.3.2 contains a remote code execution vulnerability by chaining two flaws: an arbitrary file upload and a path traversal in the Core Config Snapshots interface
CVE-2020-27534Medium· 5.3moby/buildkit: calls os.OpenFile with a potentially unsafe qemu-check temporary pathname (CVE-2020-27534)
CVE-2023-7260High· 7.5Path Traversal vulnerability discovered in OpenText™ CX-E Voice, affecting all version through 22.4