---
id: CVE-2025-10950
title: >-
  A vulnerability was determined in geyang ml-logger up to
  acf255bade5be6ad88d90735c8367b28cbe3a743
summary: >-
  A vulnerability was determined in geyang ml-logger up to
  acf255bade5be6ad88d90735c8367b28cbe3a743. Affected is the function log_handler
  of the file ml_logger/server.py of the component Ping Handler. This
  manipulation of the argument data…
severity: medium
cvss: 6.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L'
cwe:
  - CWE-20
  - CWE-502
vendor: ml-logger
product: ml-logger
affected:
  - ml-logger <= 0.10.36
published: '2025-09-25'
updated: '2026-10-11'
sourceUpdated: '2026-10-11T20:10:00.200'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-10950'
references:
  - url: 'https://github.com/geyang/ml-logger/issues/72'
    label: cna@vuldb.com
  - url: 'https://vuldb.com/?ctiid.325820'
    label: cna@vuldb.com
  - url: 'https://vuldb.com/?id.325820'
    label: cna@vuldb.com
  - url: 'https://vuldb.com/?submit.652461'
    label: cna@vuldb.com
  - url: 'https://github.com/geyang/ml-logger/issues/72'
    label: 134c704f-9b21-4f2e-91b3-4a467353bcc0
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2025-10950'
  - url: 'https://github.com/geyang/ml-logger'
tags:
  - nvd
  - osv
  - pip
epss: 0.00393
epssPercentile: 0.33251
aliases:
  - GHSA-57hm-8rjv-498w
  - PYSEC-2026-1633
ecosystem: pip
ingestedAt: '2026-07-08T18:25:45.804Z'
---

## Overview

A vulnerability was determined in geyang ml-logger up to acf255bade5be6ad88d90735c8367b28cbe3a743. Affected is the function log_handler of the file ml_logger/server.py of the component Ping Handler. This manipulation of the argument data causes deserialization. It is possible to initiate the attack remotely. The exploit has been publicly disclosed and may be utilized. This product is using a rolling release to provide continious delivery. Therefore, no version details for affected nor updated releases are available.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2025-10950)

Affected packages:

- `ml-logger <= 0.10.36`

Source: https://osv.dev/vulnerability/GHSA-57hm-8rjv-498w
