---
id: CVE-2025-12499
title: >-
  The Rich Shortcodes for Google Reviews plugin for WordPress is vulnerable to
  Stored Cross-Site Scripting via the contents of a Google Review in all
  versions up to, and including, 6.8 due to insufficient input sanitization and
  output esca…
summary: >-
  The Rich Shortcodes for Google Reviews plugin for WordPress is vulnerable to
  Stored Cross-Site Scripting via the contents of a Google Review in all
  versions up to, and including, 6.8 due to insufficient input sanitization and
  output esca…
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
published: '2025-12-06'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T20:10:00.197'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-12499'
references:
  - url: 'https://plugins.trac.wordpress.org/changeset/3389203/widget-google-reviews'
    label: security@wordfence.com
  - url: 'https://plugins.trac.wordpress.org/changeset/3411521/widget-google-reviews'
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/e2960224-4446-4fc6-8d18-6f9911b4cbad?source=cve
    label: security@wordfence.com
tags:
  - nvd
epss: 0.00383
epssPercentile: 0.32222
ingestedAt: '2026-10-27T18:12:09.296Z'
---

## Overview

The Rich Shortcodes for Google Reviews plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the contents of a Google Review in all versions up to, and including, 6.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability was partially patched in version 6.6.2.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
