---
id: CVE-2025-12764
title: "pgAdmin <= 9.9\_ is affected by an LDAP injection vulnerability in the LDAP authentication flow that allows an attacker to inject special LDAP characters in the username, causing the DC/LDAP server and the client to process an unusual amo…"
summary: "pgAdmin <= 9.9\_ is affected by an LDAP injection vulnerability in the LDAP authentication flow that allows an attacker to inject special LDAP characters in the username, causing the DC/LDAP server and the client to process an unusual amo…"
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H'
cwe:
  - CWE-90
vendor: pgadmin
product: pgadmin_4
affected:
  - pgadmin_4 < 9.10
patched:
  - pgadmin_4 9.10
published: '2025-11-13'
updated: '2026-10-07'
sourceUpdated: '2026-10-07T21:10:00.200'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-12764'
references:
  - url: 'https://github.com/pgadmin-org/pgadmin4/issues/9325'
    label: f86ef6dc-4d3a-42ad-8f28-e6d5547a5007
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2025-12764'
  - url: >-
      https://github.com/pgadmin-org/pgadmin4/commit/09d2b7eeb0e330df73b1aef0cba57788fde52b6b
  - url: 'https://github.com/pgadmin-org/pgadmin4'
tags:
  - nvd
  - osv
  - pip
epss: 0.00476
epssPercentile: 0.409
aliases:
  - GHSA-cvf4-f829-762v
  - PYSEC-2026-1772
ecosystem: pip
ingestedAt: '2026-07-08T18:25:48.577Z'
---

## Overview

pgAdmin <= 9.9  is affected by an LDAP injection vulnerability in the LDAP authentication flow that allows an attacker to inject special LDAP characters in the username, causing the DC/LDAP server and the client to process an unusual amount of data DOS.

## Affected

- `pgadmin_4 < 9.10`

## Remediation

Upgrade past the affected range:

- `pgadmin_4 9.10`

## Package advisory (CVE-2025-12764)

Affected packages:

- `pgadmin4 < 9.10`

Patched in:

- `pgadmin4 9.10`

Source: https://osv.dev/vulnerability/GHSA-cvf4-f829-762v
