---
id: CVE-2025-12765
title: "pgAdmin <= 9.9\_ is affected by a\_vulnerability in the LDAP authentication mechanism allows bypassing TLS certificate verification."
summary: "pgAdmin <= 9.9\_ is affected by a\_vulnerability in the LDAP authentication mechanism allows bypassing TLS certificate verification."
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N'
cwe:
  - CWE-295
vendor: pgadmin
product: pgadmin_4
affected:
  - pgadmin_4 < 9.10
patched:
  - pgadmin_4 9.10
published: '2025-11-13'
updated: '2026-10-07'
sourceUpdated: '2026-10-07T21:10:00.200'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-12765'
references:
  - url: 'https://github.com/pgadmin-org/pgadmin4/issues/9324'
    label: f86ef6dc-4d3a-42ad-8f28-e6d5547a5007
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2025-12765'
  - url: >-
      https://github.com/pgadmin-org/pgadmin4/commit/09d2b7eeb0e330df73b1aef0cba57788fde52b6b
  - url: 'https://github.com/pgadmin-org/pgadmin4'
tags:
  - nvd
  - osv
  - pip
epss: 0.0023
epssPercentile: 0.13733
aliases:
  - GHSA-g4r8-3qmh-pmch
  - PYSEC-2026-1773
ecosystem: pip
ingestedAt: '2026-07-08T18:25:49.222Z'
---

## Overview

pgAdmin <= 9.9  is affected by a vulnerability in the LDAP authentication mechanism allows bypassing TLS certificate verification.

## Affected

- `pgadmin_4 < 9.10`

## Remediation

Upgrade past the affected range:

- `pgadmin_4 9.10`

## Package advisory (CVE-2025-12765)

Affected packages:

- `pgadmin4 < 9.10`

Patched in:

- `pgadmin4 9.10`

Source: https://osv.dev/vulnerability/GHSA-g4r8-3qmh-pmch
