---
id: CVE-2025-13642
title: >-
  The Paid Membership Plugin, Ecommerce, User Registration Form, Login Form,
  User Profile & Restrict Content – ProfilePress plugin for WordPress is
  vulnerable to arbitrary shortcode execution in all versions up to, and
  including, 4.16.7 du…
summary: >-
  The Paid Membership Plugin, Ecommerce, User Registration Form, Login Form,
  User Profile & Restrict Content – ProfilePress plugin for WordPress is
  vulnerable to arbitrary shortcode execution in all versions up to, and
  including, 4.16.7 du…
severity: medium
cvss: 5.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N'
cwe:
  - CWE-94
published: '2025-12-09'
updated: '2026-10-07'
sourceUpdated: '2026-10-07T20:10:01.970'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2025-13642'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/wp-user-avatar/trunk/src/Classes/FormPreviewHandler.php#L15
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/wp-user-avatar/trunk/src/Classes/FormPreviewHandler.php#L71
    label: security@wordfence.com
  - url: 'https://plugins.trac.wordpress.org/changeset/3408055/'
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/4736d139-814e-4eeb-91e8-5ee41fc35a8f?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00478
epssPercentile: 0.41432
ingestedAt: '2026-10-07T20:46:46.785Z'
vendor: properfraction
product: >-
  Paid Membership Plugin, Ecommerce, User Registration Form, Login Form, User
  Profile & Restrict Content – ProfilePress
affected:
  - >-
    paid_membership_plugin_ecommerce_user_registration_form_login_form_user_profile_restrict_content_profilepress
    <= 4.16.7
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2025-12-09T15:53:52.116928Z'
---

## Overview

The Paid Membership Plugin, Ecommerce, User Registration Form, Login Form, User Profile & Restrict Content – ProfilePress plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 4.16.7 due to insufficient input sanitization on the `type` parameter in the form preview functionality. This makes it possible for authenticated attackers, with Subscriber-level access and above, to execute arbitrary shortcodes via the `pp_preview_form` endpoint.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
