---
id: CVE-2025-14727
title: NGINX Ingress Controller vulnerability
summary: "A vulnerability exists in NGINX Ingress Controller's nginx.org/rewrite-target\_annotation validation. \n\n\nNote: Software versions which have reached End of Technical Support (EoTS) are not evaluated."
severity: high
cvss: 8.3
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L'
cvssSource: cna
cwe:
  - CWE-22
vendor: F5
product: NGINX Ingress Controller
affected:
  - nginx_ingress_controller >= 5.3.0 < 5.3.1
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2025-12-18T04:55:23.427345Z'
published: '2025-12-17'
updated: '2026-11-03'
sourceUpdated: '2026-11-03T22:02:51.647Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2025-14727'
references:
  - url: 'https://my.f5.com/manage/s/article/K000158176'
tags:
  - cve.org
epss: 0.00434
epssPercentile: 0.37887
ingestedAt: '2026-11-05T20:33:06.532Z'
---

## Overview

A vulnerability exists in NGINX Ingress Controller's nginx.org/rewrite-target annotation validation. 


Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

## Affected

- `nginx_ingress_controller >= 5.3.0 < 5.3.1`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
