---
id: CVE-2025-2000
aliases:
  - GHSA-6m2c-76ff-6vrf
title: Qiskit allows arbitrary code execution decoding QPY format versions < 13
summary: Qiskit allows arbitrary code execution decoding QPY format versions < 13
severity: critical
cvss: 9.8
cwe:
  - CWE-502
vendor: qiskit-terra
product: qiskit-terra
ecosystem: pip
affected:
  - 'qiskit-terra >= 0.18.0, <= 0.46.3'
  - qiskit <= 1.4.1
  - qiskit = 2.0.0rc1
patched:
  - qiskit 1.4.2
  - qiskit 2.0.0rc2
published: '2025-03-14'
updated: '2026-11-04'
sourceUpdated: '2026-11-04T16:26:24Z'
source: GHSA
sourceUrl: 'https://github.com/advisories/GHSA-6m2c-76ff-6vrf'
references:
  - url: 'https://github.com/Qiskit/qiskit/security/advisories/GHSA-6m2c-76ff-6vrf'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2025-2000'
  - url: 'https://www.ibm.com/support/pages/node/7185949'
  - url: 'https://github.com/advisories/GHSA-6m2c-76ff-6vrf'
tags:
  - ghsa
  - pip
epss: 0.0081
epssPercentile: 0.57146
ingestedAt: '2026-11-04T17:19:45.136Z'
---

## Overview

### Impact

A maliciously crafted QPY file can potentially execute arbitrary-code embedded in the payload without privilege escalation when deserializing QPY formats < 13. A python process calling Qiskit's `qiskit.qpy.load()` function could potentially execute any arbitrary Python code embedded in the correct place in the binary file as part of a specially constructed payload.

### Patches

Fixed in Qiskit 1.4.2 and in Qiskit 2.0.0rc2

## Affected packages

- `qiskit-terra >= 0.18.0, <= 0.46.3`
- `qiskit <= 1.4.1`
- `qiskit = 2.0.0rc1`

## Remediation

Upgrade to a patched release:

- `qiskit 1.4.2`
- `qiskit 2.0.0rc2`
