CVE-2025-22258Medium· 5.7▾ SunlitA heap-based buffer overflow in Fortinet FortiSRA 1.5.0, 1.4.0 through 1.4.2, FortiPAM 1.5.0, 1.4.0 through 1.4.2, 1.3.0 through 1.3.1, 1.2.0, 1.1.0 through 1.1.2, 1.0.0 through 1.0.3, FortiProxy 7.6.0 through 7.6.1, 7.4.0 through 7.4.7,…
▾ Sunlit zone — Low / medium · no exploitation signal
impact 31.4 · likelihood 0.1 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Stakeholder-Specific Vulnerability Categorization from CISA's ADP record at CVE.org: whether exploitation is observed, whether an attack can be automated, and how much of the system is at stake. The CVSS score shown above comes from the assigning CNA record, not NVD.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via CVEORG
Last analysed / modified upstream
0.6%
A heap-based buffer overflow in Fortinet FortiSRA 1.5.0, 1.4.0 through 1.4.2, FortiPAM 1.5.0, 1.4.0 through 1.4.2, 1.3.0 through 1.3.1, 1.2.0, 1.1.0 through 1.1.2, 1.0.0 through 1.0.3, FortiProxy 7.6.0 through 7.6.1, 7.4.0 through 7.4.7, FortiOS 7.6.0 through 7.6.2, 7.4.0 through 7.4.6, 7.2.0 through 7.2.10, 7.0.2 through 7.0.16, FortiSwitchManager 7.2.1 through 7.2.5 allows attackers to escalate their privilege via specially crafted http requests.
FortiPAM 1.5.0FortiPAM >= 1.4.0 <= 1.4.2FortiPAM >= 1.3.0 <= 1.3.1FortiPAM 1.2.0FortiPAM >= 1.1.0 <= 1.1.2FortiPAM >= 1.0.0 <= 1.0.3FortiOS >= 7.6.0 <= 7.6.2FortiOS >= 7.4.0 <= 7.4.6FortiOS >= 7.2.0 <= 7.2.10FortiOS >= 7.0.2 <= 7.0.16FortiSRA 1.5.0FortiSRA >= 1.4.0 <= 1.4.2FortiProxy >= 7.6.0 <= 7.6.1FortiProxy >= 7.4.0 <= 7.4.7FortiSwitchManager >= 7.2.1 <= 7.2.5Upgrade to FortiPAM version 1.6.0 or above Upgrade to FortiPAM version 1.5.1 or above Upgrade to FortiPAM version 1.4.3 or above Fortinet remediated this issue in FortiSASE version 25.1.b and hence customers do not need to perform any action. Upgrade to FortiOS version 7.6.3 or above Upgrade to FortiOS version 7.4.7 or above Upgrade to FortiOS version 7.2.11 or above Upgrade to FortiOS version 7.0.17 or above Upgrade to FortiSRA version 1.6.0 or above Upgrade to FortiSRA version 1.5.1 or above Upgrade to FortiSRA version 1.4.3 or above Upgrade to FortiProxy version 7.6.2 or above Upgrade to FortiProxy version 7.4.8 or above Upgrade to FortiSwitchManager version 7.2.6 or above
Connected by shared product, vendor, weakness, or advisory.
CVE-2025-57740Medium· 6.7An Heap-based Buffer Overflow vulnerability [CWE-122] in FortiOS version 7.6.2 and below, version 7.4.7 and below, version 7.2.10 and below, 7.0 all versions, 6.4 all versions; FortiPAM version 1.5.0, version 1.4.2 and below, 1.3 all ver…
CVE-2024-50571Medium· 6.5A heap-based buffer overflow vulnerability in Fortinet FortiAnalyzer 7.6.0 through 7.6.2, FortiAnalyzer 7.4.0 through 7.4.5, FortiAnalyzer 7.2.0 through 7.2.9, FortiAnalyzer 7.0.0 through 7.0.13, FortiAnalyzer 6.4 all versions, FortiAnal…
CVE-2025-25249High· 8.1A heap-based buffer overflow vulnerability in Fortinet FortiOS 7.6.0 through 7.6.3, FortiOS 7.4.0 through 7.4.8, FortiOS 7.2.0 through 7.2.11, FortiOS 7.0.0 through 7.0.17, FortiOS 6.4 all versions, FortiSwitchManager 7.2.0 through 7.2.6…
CVE-2023-27997Critical· 9.8A heap-based buffer overflow vulnerability [CWE-122] in FortiOS version 7.2.4 and below, version 7.0.11 and below, version 6.4.12 and below, version 6.0.16 and below and FortiProxy version 7.2.3 and below, version 7.0.9 and below, versio…
CVE-2026-39814Medium· 6.2Multiple Relative Path Traversal vulnerabilities [CWE-23] vulnerability in Fortinet FortiWeb 8.0.0 through 8.0.2, FortiWeb 7.6.0 through 7.6.6, FortiWeb 7.4.1 through 7.4.13, FortiWeb 7.2.7 through 7.2.13, FortiWeb 7.0.10 through 7.0.12 …
CVE-2025-47761High· 7.1An Exposed IOCTL with Insufficient Access Control vulnerability [CWE-782] vulnerability in Fortinet FortiClientWindows 7.4.0 through 7.4.3, FortiClientWindows 7.2.0 through 7.2.9 may allow an authenticated local user to execute unauthori…