---
id: CVE-2025-26269
title: >-
  DragonflyDB Dragonfly through 1.28.2 (fixed in 1.29.0) allows authenticated
  users to cause a denial of service (daemon crash) via a Lua library command
  that references a large negative integer.
summary: >-
  DragonflyDB Dragonfly through 1.28.2 (fixed in 1.29.0) allows authenticated
  users to cause a denial of service (daemon crash) via a Lua library command
  that references a large negative integer.
severity: low
cvss: 3.3
cvssVector: 'CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L'
cvssSource: cna
cwe:
  - CWE-191
vendor: DragonflyDB
product: Dragonfly
affected:
  - Dragonfly <= 1.28.2
ssvc:
  exploitation: poc
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2025-04-23T16:08:08.337663Z'
exploitAvailable: true
published: '2025-04-17'
updated: '2026-11-03'
sourceUpdated: '2026-11-03T22:02:56.763Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2025-26269'
references:
  - url: 'https://github.com/dragonflydb/dragonfly/issues/4468'
  - url: >-
      https://github.com/dragonflydb/dragonfly/commit/4612aec9a78e3f604e6fb19bee51acde89723308
  - url: 'https://gist.github.com/ankki-zsyang/d8215cf6e868d07546eaa5346a884ebd'
tags:
  - cve.org
  - exploit-available
epss: 0.00292
epssPercentile: 0.21897
ingestedAt: '2026-11-05T20:33:06.545Z'
---

## Overview

DragonflyDB Dragonfly through 1.28.2 (fixed in 1.29.0) allows authenticated users to cause a denial of service (daemon crash) via a Lua library command that references a large negative integer.

## Affected

- `Dragonfly <= 1.28.2`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
