---
id: CVE-2025-2938
title: Business Logic Errors in GitLab
summary: >-
  An issue has been discovered in GitLab CE/EE affecting all versions from 17.3
  before 17.11.5, 18.0 before 18.0.3, and 18.1 before 18.1.1 that could have
  allowed authenticated users to gain elevated project privileges by requesting
  access…
severity: low
cvss: 3.1
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-840
vendor: GitLab
product: GitLab
affected:
  - GitLab >= 17.3 < 17.11.5
  - GitLab >= 18.0 < 18.0.3
  - GitLab >= 18.1 < 18.1.1
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2025-06-27T03:55:22.451517Z'
published: '2025-06-26'
updated: '2026-11-03'
sourceUpdated: '2026-11-03T22:02:57.331Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2025-2938'
references:
  - url: 'https://gitlab.com/gitlab-org/gitlab/-/issues/529006'
    label: 'GitLab Issue #529006'
  - url: 'https://hackerone.com/reports/3063091'
    label: 'HackerOne Bug Bounty Report #3063091'
tags:
  - cve.org
epss: 0.00318
epssPercentile: 0.2492
ingestedAt: '2026-11-05T20:33:06.547Z'
---

## Overview

An issue has been discovered in GitLab CE/EE affecting all versions from 17.3 before 17.11.5, 18.0 before 18.0.3, and 18.1 before 18.1.1 that could have allowed authenticated users to gain elevated project privileges by requesting access to projects where role modifications during the approval process resulted in unintended permission grants.

## Affected

- `GitLab >= 17.3 < 17.11.5`
- `GitLab >= 18.0 < 18.0.3`
- `GitLab >= 18.1 < 18.1.1`

## Remediation

Upgrade to versions 17.11.5, 18.0.3, 18.1.1 or above.
